New PC Build Won't Boot - Did I Troubleshoot it Right?

Gosunkgugi

Reputable
Sep 10, 2014
7
0
4,510
0
Hello, friends. I just put together a new PC, and it's not doing much of anything. This is not the first PC I've put together (although the previous ones were Intel rather than AMD - I should never have gotten experimental), but I seem to have failed somewhere important. I followed the steps recommended before posting, and have looked in many other 'no POST' threads as well.

My system:
ASUS Radeon RX 580 4GB Dual
WD Blue 3D 500GB 2.5" SSD
Uppgraderingspaket - Ryzen 7 2700X
AMD Ryzen 7 2700X Prosessor
ASUS ROG STRIX B450-F GAMING, Socket-AM4
Ballistix Sport LT DDR4 16GB (2x8)
Fractal Design Core 2500 Midi Tower
Corsair CX550M, 550W PSU
WD Desktop Blue 2TB 3.5"

I don't have a motherboard speaker, but the "DRAM error" LED is glowing, and the computer won't boot. I have tried both RAM sticks in every slot, to no avail, and I have attempted to breadboard the whole thing by connecting only the PSU, PCU and one RAM stick in the RAM slot indicated by the owner's manual. I still get the same error, no matter what I do.

Additionally, although I don't know if it matters - with the computer on and refusing to boot, I am able to connect USB devices to the PC and get a brief blip of acknowledgement from the device, but I can't, say, charge anything via the USB slots.

Personally, I suspect the motherboard broke during installation, as the accursed thing is designed like a freaking spaceship, incredibly heavy, and so spiky I had to cut it out of the antistatic bag. I don't see any bent pins, but I ended up touching it in a lot of places to avoid having it break under its own weight.

Anyway, my plan is this:
1. Buy another identical set of RAM sticks (which won't be in stock for another two weeks, naturally...) and try the motherboard with those. Worst case scenario, I end up with twice as much RAM in the end.

2. Pull out CPU and check for broken pins. There were none when I inserted it, but I had some difficulty wrangling that strange, screw-less attachment thingy with the lever, so I wouldn't be terribly surprised if something broke at that stage. Either way, the cooling paste is stuck on rock-hard, so the less I need to mess with that, the better.

3. If no broken pins are found, try to return motherboard to supplier and hope for the best.

What do you think? Is this a reasonable plan of action? Feel free to laugh at my incompetence, I clearly had no idea what I was getting into.
 

Supahos

Champion
Herald
I'd make step 1 step 3 but other than that sounds reasonable. All troubleshooting must be done with the GPU installed as well. You don't have any on board video on your processor so you'll never get a signal without a gpu
 

QwerkyPengwen

Dignified
Herald
like supahos said, unlike all the intel chips, unless there is a G at the end of the model name, then Ryzen CPU's don't have on board graphics and you need to have a GPU installed and the video cable plugged into it to get video on the monitor.

There is no such thing as a motherboard breaking under it's own weight, motherboards (while quite flexible) are extremely durable and take a lot more to break than most anyone thinks.

Double check that the CPU power cables, 24pin motherboard power, and GPU power are FULLY plugged in, if unplugged by even a hairline amount and stuff won't work.
 

Gosunkgugi

Reputable
Sep 10, 2014
7
0
4,510
0
I'm using 2666Mhz RAM modules, although they came as a package deal with the mobo and CPU, and were promised to be compatible.

Well, I can plug in the GPU easy enough, of course, but don't I have to get rid of the DRAM LED issue before that starts to matter?

I will check the 24pin connector again.

Sadly, I don't have any 2400Mhz RAM modules I can borrow - or any RAM modules at all, for that matter. I'm the only person I know who's upgraded to DDR4 at this point.

And one last question - right now, I have the motherboard set on the box it came in. Is it safe to plug anything in like this? Won't that risk breaking the pins on the backside?

Thank you very much for the advice, I will return tomorrow with further results.
 

Supahos

Champion
Herald
No as mentioned they're pretty tough and it's just cardboard on the backside. I would guess that's not your problem just letting you know it can't work without a gpu.

I would look the CPU pins over when you got a chance. Just be careful when removing the heatsink if it's stuck pretty firmly you can rip the cpu out of the socket and kill it
 

Similar threads


ASK THE COMMUNITY

TRENDING THREADS