Question New PC but no signal detected on monitor

Mar 16, 2019
3
0
10
Best answers
0
Hi guys,

I've just building up my new pc with these components:

Asus TUF Z390-PLUS GAMING
Intel Core i5-8600K
Asus ROG-STRIX-RTX2070-O8G-GAMING
Corsair TX750M
Samsung MZ-V7S500BW Unità SSD 970 EVO PLUS
Corsair Vengeance LPX 16 GB (2 X 8 GB), DDR4, 3000 MHz, C15 XMP 2.0

when I start it up all fans and leds work, but no signal detected on monitor. Monitor and hdmi cable are working because I tested them on a lapotop. I tried to remove hard disk, ssd, graphic card and connect hdmi cable directly to motherboard but still not working.

Any help? What could be the problem?

Regards,
Andrea
 
Mar 16, 2019
3
0
10
Best answers
0
Thanks for thw reply; anyway I also tried the hdmi and the display port directly from the motherboard removing the graphic card, but still not working.

Any other idea?
 

Vic 40

Titan
Herald
Oct 22, 2013
15,268
39
73,440
Best answers
2,371
Can only suggest to rebuild completely,check all connections twice and make sure you have the manuals next to you.
Also check the motherboard socket for bend pins whe doing that.Take a strong light and if you have it a magnifying glas to look. Can also make a picture with your phone if it has a good camera and check via that. Hope the cooler you use came with a tube of paste.
 
Mar 16, 2019
3
0
10
Best answers
0
At the end I returned the motherboard, ram and cpu to the vendor and bought a new of each one and now everything works.
I suspect that the problem was on the motherboard because at the startup no led except for the aura ones lighted on; it seemed like dead.

Anyway, thanks everyone!
 

ASK THE COMMUNITY

TRENDING THREADS