Question New PC, external HD disconnecting and preventing boot.

Feb 21, 2020
2
0
10
0
Hello everyone,
So, I recently built a new computer used predominantly as a Plex media server to replace my older sluggish one. I had 3 external usb hard drives attached to my old computer, one of which was a 6tb Seagate, containing all of my media, all working perfectly. After the build, I simply connected these externals to the new machine. One of these externals is causing 2 issues:

  1. The new computer will not boot (won't even get to bios screen) if that drive is plugged in. Unplugging, she boots perfectly. Then plugging in after, it seems to work perfectly.
  2. After a short while, the drive will disconnect and reconnect - seemingly every 10min or so. When connecting the drive, the drive folder pops up, so I can always tell if the drive had disconnected & reconnected if I stepped away because the drive folder will be on the screen.
New build:
B450 Tomahawk Max - Ryzen 7 2700
Radeon 3850 graphics (repurposed from my old machine for now)
16GB DDR4 3200MHz
Samsung 970 EVO 500GB NVMe M.2
Windows 10 Home (up to date)
4 internal hard drive (4tb, 2tb, 1tb, 1tb)
3 external hard drives (6tb, 4tb, 2tb)

This is what I've tried with no success:
  • Updated driver files (although there seems to be no driver download for Seagate external drives)
  • Tried different USB ports.
  • Tried new USB cable for the drive.
  • Tried "wiggling" the USB cable to reproduce the problem (cannot reproduce).
  • Checked my drive format in disk management - Healthy (Primary Partition) NTFS
  • Bios is not using USB as primary boot drive, and no system files on this external (only media).
  • Power options changed to high performance; turned OFF usb drive suspend; and disabled "allow computer to turn off this device".
  • Downloaded the Seagate HD toolkit thing and scanned the drive - no issues. Used windows scan - no issues. Defrag - no bad sectors.
  • Tried disconnecting all the other USB drives, and having just that one drive connected.
  • Tried some Registry fix listed here: https://community.spiceworks.com/topic/2122647-seagate-4tb-expansion-drive-keeps-disconnecting
Things I haven't tried:
  • Updating the USB 3.0 controller drivers (I cannot find any updated drivers on the MSI website).
  • Disabling legacy USB support in Bios (I'm afraid I'll lose my USB keyboard and not be able to access Bios to reverse it).
  • And I'm putting this here as a reminder to me to check this when I get home: I never actually checked the power cord for the drive, and I never checked the drive on another computer.
I'm sure some would be quick to assume the drive is failing, but I can't believe that it was a coincidence the drive is failing the exact same time I switched it to a new computer.

Just so frustrating. Thanks anyone for any help you can provide.
 
Feb 21, 2020
2
0
10
0
Update. The drive in question failed. So it wasn't a software or other hardware issue. It was a drive failure. Unsure it it's the drive or the USB controller.
Going to remove the drive from its enclosure and see if it works.
 

ASK THE COMMUNITY

TRENDING THREADS