Question New PC keeps freezing when in Windows AND BIOS

Nov 13, 2021
4
0
10
0
Hello!
So, I have bought a new PC (ready made, with the shop's parts) and after I installed win 10 on it and after doing its updates and installing the GPU's drivers, I have encountered some problems.
When listening to music, the PC just froze and I couldn't do anything to it (the keyboard and the mouse didn't work as well) so I just forced a restart. The second time, it was during a movie and this time I observed that even in BIOS, it keeps freezing (by freezing in BIOS I mean I can't use neither the mouse or keyboard). This time though, the whole PC started to act weird: upon restart or start up, the motherboard takes a lot of time to beep and sometimes now doesn't even enter, my screen is just black but the system is on (weird!!) so the GIGABYTE logo doesn't even come up. It's as if I only turned on the monitor. I also observed that when hitting the power button, the system starts but then stops and restarts again... and it is on a loop as if it doesn't have power?? But it does, the power supply is ok.
I hope I am explaining well, I apologize for the entangled explanations.


What could it be??
My system: Intel Core i9-9900 3.1 Ghz, 16 gb ddr4, ssd 240 gb and hdd 500 gb with a dedicated Nvidia Quadro K620 2GB/128 bit. The motherboard is GIGABYTE, the psu is Spacer ATX 500 v12.

(I bought this PC system as a whole so that's why I didn't specify the producer of some pieces; I don't know) I'm not savy in tech. Please help!! (Thank you!)

UPDATE: I wanted to turn on the PC this morning and it didn't even turn on, it's on a loop or restarting without giving any image/logo on the screen. The system starts (the fans start, the motherboard beeps) but then it shuts down and begins again.
 
Last edited:
Nov 13, 2021
4
0
10
0
check cpu/gpu temp?
what is on the hdd?
brand and model of the psu?
Hi! I have checked the temperatures and nothing seemed out of the ordinary; the CPU had a constant 39-40 and the GPU the same 33-35.
Regarding the HDD, nothing was installed on it... I only installed the win on the ssd.
The psu is Spacer ATX 500 v12
 

ASK THE COMMUNITY

TRENDING THREADS