Question New PC not seeing i7 10700k IGPU

May 1, 2020
22
5
515
0
So I just built a new PC. I haven't built in a long time though so I'm rusty. UEFI didn't even exist the last time I did this.

Originally when I first booted it up, I had the HDMI cable in the mobo with no GPU, and I got to the UEFI screen, so I'm assuming the IGPU was working at that point. But I shut down and then installed the GPU and moved the HDMI over to that and booted up from there. Everything was fine and I installed Windows and updated my GPU drivers, and now it's not seeing any integrated graphics. I tried booting again with the HDMI in the mobo, but I get no screen.

I'm using an MSI z490 - A Pro motherboard.
Geforce RTX 3080 latest game ready driver
Intel i7 10700k
Windows 10 Pro
32GB Crucial Ballistix DDR-3200 CL16 Memory
m.2 SSD
3'5 HDD


Everything else seems to be working perfectly. It's just the integrated graphics that aren't showing up. I tried googling and looking around the UEFI, but I can't find where I can see if it is disabled. Google showed severarl results for this CPU's IGPU not showing up, but I couldn't find an answer that helped me with my lack of experience.

I greatly appreciate any help/advice.

Thank you for your time.
 

Wolfshadw

Titan
Moderator
Check your motherboard's manual (apparently not available online). Should be in the BIOS section. Look for items like IGX and set to enable. On my MSI B450 Pro-A, it's listed under the Advanced Section.
Look for Integrated Graphics (Auto)
Set it to Force.

This (if found in your BIOS screen) should re-enable the integrated graphics of your motherboard.

-Wolf sends

Edit:

Now it's available:
https://download.msi.com/archive/mnu_exe/mb/E7C75v1.1.pdf
Integrated Graphics Configuration Sub-Menu

See Pg. 54.
 

ASK THE COMMUNITY

TRENDING THREADS