Question New PC randomly 'turning off' but then wont power back on correctly.

Romeski

Commendable
Jun 27, 2019
30
0
1,530
0
Recently built a new rig as I'm moving for university. The specs are:
MOBO: X570 I Aorus pro wifi
CPU: ryzen 5 5600x
CPU cooler: Kraken X63 (replaced fans with noctua NF-A14s)
RAM: Crucial Ballistix 3600mhz (2x8gb)
GPU: GTX 1050 TI (i know its odd but built using old GPU as i want to still use my current pc before moving, will then transfer current GPU)
SSD: Crucial P5 1TB
PSU: Corsair SF750
Chassis: SSUPD meshlicious
OS: Windows 10 64bit

I built the rig about 1-2 months ago, installed windows and set up all the basics with everything going smoothly so I was chuffed. Then left to sit until a week ago, the issues started few days ago. My PC randomly shut down over night while i left it installing games. I thought the PC had just gone to sleep but it turns out the system was still 'on'. AIO still all on, power button lit up, MOBO lights on and GPU fan spinning but nothing showing on monitor. I then tried to turn it off using the power button but nothing was happening. After a few attempts of using the power button i resorted to the PSU power switch, thinking it was just a hard crash or something. Turned off just fine so I tried turning it on again. Turned on fine with no issues and also was able to turn off using the power button. Left on and tried to install games over night again, but the same thing happened. The PC is basically unusable now due to it randomly turning 'off', but all the components, lights and fans remain on. I haven't tried to troubleshoot much as i have no clue what the issue is here as well as the random shut downs limiting what i can do (I've tried to do a clean install of windows and everything but cant even do that without the turning off). This is only my 3rd build so I'm inexperienced.
 
Last edited:

ASK THE COMMUNITY