Question New PC wont display anything

chri

Distinguished
Nov 21, 2013
43
0
18,530
0
I just put together new PC with these specs, it wont display anything on monitor and also shows CPU debug light on mobo. I have updated the BIOS using memory stick, still doesnt work. I am using 8 pin power for the CPU (not the 4 pin shown in pic).PLEASE HELP !! :):):)

MOBO: MSI 7590 - A - PRO
CPU: i7 10700K
CPU cooler: Cooler Master i50C
GPU: 3060
RAM: Corsair Vengeance 3600 RGB
PSU: Corsair RM750

View: https://imgur.com/hAoaEUz

View: https://imgur.com/ZfIyluf

View: https://imgur.com/9DQs41A

View: https://imgur.com/WA2LQtb
 

rakibfahadgts

Reputable
Aug 4, 2018
138
14
4,595
2
Why did you have to update the bios? Just asking. Z590 is for 11th gen and backward compatible with 10th gen. So being the newer gen it should work out of the box for 10th gen. If you have spare 1200 socket CPU plug it and see if that works. If not take out CMOS battery (seek YouTube how to do it if don't know). Try only one stick of ram. Very necessary: Is the CPU fan plugged in CPU fan header. Otherwise PC won't boot. Also what's up with that CPU cooler. It'll not do justice with your 10700k specially overclocked one. At times CPU debug light will show because of GPU issue. But that happens with AMD CPUs which don't have igpu. Very unlikely for Intel.
 

chri

Distinguished
Nov 21, 2013
43
0
18,530
0
I read some dont come with the latest BIOS so I updated Just incsase.

I don’t have spare CPU. Have tried one stick of RAM. CPU fan plugged in and working. Will try taking out CMOS. Thank you
 

Remeca

Respectable
Aug 30, 2019
768
142
2,340
81
Next step would be taking out the cpu, checking for bent pins, resetting the CMOS, reseating the cpu and HSF, any other troubleshooting steps offered by your motherboard manual, and perhaps contacting their support if it still doesn't work.
 

ASK THE COMMUNITY

TRENDING THREADS