Question New PC wont POST, no beep codes

Apr 14, 2020
1
0
10
0
I'm a first time PC builder and am having a lot of trouble with my first build. I've tried everything i know, done as much trouble shooting as a i can, and i have no idea why it will not post or boot to bios. It turns on, and all the fans spin, and the (Very minimal) LEDs on the case light up.

Build in question:
MB: ASROCK B450M-HDV R4.0 AM4/AMD (Open box from Newegg)
CPU: Ryzen 3 1200 (Used)
RAM: 1 Stick: G.Skil NT series 8GB 288pin DDR4 Model: F4-2400C15S-8GNT (New from Newegg)
GPU: XFX Radeon RX 570 Model: RX-570P8DFD6 (New from Newegg)
PSU: RAIDMAX XT Series RX-500XT( New from Newegg)
Case: Cooler master 1200 (used)

I first didn't have the CPU power connected, after plugging in the 4-pin CPU power, the system still did not power on. After that i took the entire system apart and Bread boarded the MB and CPU, re-slotting the ram, and trying it with and without the GPU, and it still didn't post. At the time i did not have a MB speaker, so after ordering one, i tried both things again, Making sure everything was plugged in, trying with the GPU taken out, Trying with the ram taken out, and it still didn't beep. At this point I'm thinking that it's either the CPU, RAM, or MB itself. I don't have the spare parts to test each part individually. What should be my course of action.
 

ASK THE COMMUNITY

TRENDING THREADS