Question New PC wont post (video)

Dec 9, 2022
4
0
10
0
Hey! I just built a PC and it simply wont post to bios. I’ve tried rebuild it from scratch, tried using only 1 Ram stick etc but all it does is showing me the White light. I recorded how the PC is acting.

It looks like its stuck on a bootlooping or something, the VGA light stays on for around 15 secs, then DRAM and CPU lights up and then it repeats the cycle. A faulty PSU perhaps? You can see the video on the Imgur link, I couldnt figure out how to embedd it here

Yes, I’ve tried using the mobo-HDMI as well with no results. I’ve also tried to reset CMOS. I have tried the rams on different slots, solo and duo.



UPDATE:
After flashing bios, evertything is up and running!
 
Last edited:

Lutfij

Titan
Moderator
Welcome to the forums, newcomer!

Apart from starting at a video of a motherboard's debug LED's we have no idea what you're working with. When posting a thread of troubleshooting nature, it's customary to include your full system's specs. Please list them like so:
CPU:
Motherboard:
Ram:
SSD/HDD:
GPU:
PSU:
Chassis:
OS:
Monitor:
 
Dec 9, 2022
4
0
10
0
Welcome to the forums, newcomer!

Apart from starting at a video of a motherboard's debug LED's we have no idea what you're working with. When posting a thread of troubleshooting nature, it's customary to include your full system's specs. Please list them like so:
CPU:
Motherboard:
Ram:
SSD/HDD:
GPU:
PSU:
Chassis:
OS:
Monitor:
I did include the specs, its over the video ^^
The monitor is an MSI OPTIX G27C6
 

Lutfij

Titan
Moderator
Sorry, now I see it, had to enable my VPN to see the image you'd linked above the video's URL.

You could try and avail he BIOS flashback option on your motherboard, outlined in page 2-19, here. Use the latest BIOS version before attempting to flash the BIOS with the USB drive+button.

If you think the PSU is the issue, remove the discrete GPU and power off the iGPU.
 
Dec 9, 2022
4
0
10
0
Sorry, now I see it, had to enable my VPN to see the image you'd linked above the video's URL.

You could try and avail he BIOS flashback option on your motherboard, outlined in page 2-19, here. Use the latest BIOS version before attempting to flash the BIOS with the USB drive+button.

If you think the PSU is the issue, remove the discrete GPU and power off the iGPU.
will try updating the bios. What did you mean with power off the iGPU?
 

ASK THE COMMUNITY

TRENDING THREADS