Question New PC won't start but USB has power

Feb 9, 2021
3
0
10
0
Hi folks,

New here and hoping somebody might be able to shed some light on my problem. It's been a while since I built a computer myself, and to be honest thought it would be easy. Yet I have been getting super frustrated.

Here's my setup, I bought all these parts new except for the GTX 1060 which I had in my old PC.

  • CPU: AMD Ryzen 5 3600 WRAITH 3600 AM4
  • RAM: D432GB 3200-16 Fury Black
  • PSU: Corsair TX550M V2
  • MoBo: Gigabyte B550M S2H AMD B550 Socket AM4 micro ATX
  • Case: Jonsbo V4 Micro-ATX Cube
  • GPU: NVIDIA GTX 1060

The problem is that it simply won't start. The USB ports are getting power (even the external ones in the case, but that's about it. I even tried the CPU fan on my old motherboard which worked. I also tested the PSU separately, which also worked (and again USB power is working).

It's worth noting that I actually had a B450M motherboard before this but sent it back as I thought that was the problem. The vendor was super busy so I don't think they actually checked and just refunded me. I then bought the B550M (it has PCI-e 4) and I am now thinking that the mobo was never the problem as the issue is exactly the same.

What I have tried so far that did nothing: different PSU, take out RAM, take out CPU, take out videocard.

Any suggestions what I should try? Thank you for your time!!
 
Feb 9, 2021
3
0
10
0
Yes sir, just tried that again just now, nothing ...

EDIT: I am assuming you meant the HDMI from the display to the GPU right?

It's true that the CPU does not have integrated GPU so that could have been something, but unfortunately it doesn't seem to matter now
 
Last edited:

ASK THE COMMUNITY

TRENDING THREADS

Latest posts