Question New PC won't turn on - VGA not detected error

Aug 20, 2020
7
1
15
0
Hi, I bought all components online from different suppliers and LEDs on mobo display an error VGA not detected. Need to say that mobo comes with integrated GFX and I have RTX card too, tried with and without and still same error occurs accompanied by 1 long beep and 2 short beeps.

What could be broken? Looks like MoBo but how to be sure of it? This is my first AMD build, I did few builds using Intel before and had no issues at all. It took me a while to find proper RAM sticks to work with AMD CPU. I have the feeling that with Intel you just buy any sticks you want, never had to look for exact product number before. Am I missing something special AMD oriented here? Please help! :)

MOBO: ASUS Prime B550-PLUS
CPU: AMD Ryzen 9 3900X
RAM: G.Skill Ripjaws V DDR4 2x8GB 3200MHz
Cooler: NOCTUA NH-D15
Power Supply: SILENTIUM PC Supremo L2 650W
Storage: SSD SAMSUNG 970 EVO Plus NVMe M.2 1TB
VGA: MSI GeForce RTX 2060 Super VENTUS GP OC (and/or on-board)

I tried different configs of above with just mobo+cpu+cooler+ram running (without MSI gfx card and nVMe) but still got the same error unfortunately. Could it be something with cable/monitor? I have monitor with Display Port cable working with other PC but maybe I should try with HDMI cable/monitor? As far as I know it should run even with no monitor connected.
 

Barty1884

Retired Moderator
Need to say that mobo comes with integrated GFX
CPU: AMD Ryzen 9 3900X
To be clear, while the motherboard has display outputs, it requires the use of a CPU it integrated graphics (ie an APU, one of the "G" chips). The 3900X has no iGP

still same error occurs accompanied by 1 long beep and 2 short beeps.
This is going to be the main clue....
https://www.asus.com/support/FAQ/1029959/
An anomaly is detected in memory. Please confirm that the memory is correctly installed.
Please refer to the Motherboard manual for related instructions about memory.
Issue likely related to the memory, although CPU could be part (or all) of the problem.
Try booting with only a single DIMM installed, and try both individually.


Never heard of a particularly great Silentium PSU, so chances are that's a great plan for the long run, or even initially..... Might be part (or all) of the problem there, but the beep codes suggest RAM.
 
Reactions: photonTH
Aug 20, 2020
7
1
15
0
OK so I found old GeForce 8800 GTS to test the build and it works fine. So put RTX in again and it worked!
Strange thing as I put RTX out and in several times to be sure if all connectors are firmly attached. Weird.
I'll install OS and drivers and run several tests and task to test it properly.
Thanks @Barty1884 for your help!
 

ASK THE COMMUNITY

TRENDING THREADS