New Processor, No display, No Mouse Light, No Keyboard Light

mongo21

Reputable
Dec 25, 2014
10
0
4,510
0
Here are my specs:
MSI A58M-E35 Micro ATX FM2+ Motherboard
G.Skill Ripjaws Series 8GB (2 x 4GB) DDR3-1600 Memory
PowerColor Radeon HD 7770 1GB Video Card
Raidmax 530W Semi-Modular ATX Power Supply

I had a A4 6300 3.7ghz processor and I wanted a quad core cpu that works on my MB, so I bought a Athlon 860k 3.7 ghz cpu.
I replaced the cpu and cpu fan with the new ones and connected everything properly.

I started up my computer, the cpu fan works, the gpu fan works, and the computer fans also work but my display is black, my mouse doesn't light up, and neither does my keyboard.

Please help
Thanks

I also tried taking out the MB battery out for 5 seconds and also cleared the cmos but It didnt work. I also took the cpu out to see if any of the pins were bent, but everything was fine.
 

DougLYX

Distinguished
Apr 9, 2011
411
0
18,810
24
check motherboard socket for bent pins if it's lga type, if it's old style cpu with pins, check for bent pins or missing pins. if theres no problem on either,
check msi if theres a bios update for the motherboard to support the cpu. if u have final bios version and cpu still won't post, contact store about the cpu , if it doesn't help..then contact amd. either option means rma. explain to them both how u got the cpu and what steps u took to try to get it working(except the really stupid ones)
 

mongo21

Reputable
Dec 25, 2014
10
0
4,510
0
I checked to see if there were bent pins or missing pins, but there weren't any.
I think I will try to put my old cpu back in and see if it works. I will post my results.
Thanks for the help
 

mongo21

Reputable
Dec 25, 2014
10
0
4,510
0
I found the solution.
It was dumb of me not to realize this sooner but my motherboard bios wasn't updated.

All i did was change back to my old cpu, update the motherboard bios, and then replace the cpu to the newer one.
And viola, it worked.
 

ASK THE COMMUNITY

TRENDING THREADS