Question New PSU and PC still won't start

May 18, 2022
2
0
10
0
Hello everyone,

I recently got back from a 2 week break and upon sitting down at my desk and turning on my PC... nothing happened.
I tried multiple times holding down the power button to get it to turn on but nothing.
I've tried unplugging everything from the motherboard/PSU and still nothing turned on.

I've disconnected the power button cables and tried shorting, but other than the motherboard light being on (it always turns on when i plug the PSU in) shorting the connectors did not start anything (PSU fans still off, no beeps from motherboard).

I though it was just a dead PSU as mine is like 9 years old so I ordered another one, connected it but got the exact same results.

Is my motherboard dead even though the RGB light consistently turns on when the PSU switch is turned on?

System Specs:
CPU: Intel i5
Motherboard: ASUS H81M-A
RAM: 4GB (IDK what but i dont think it has any bearing on this)
GPU not connected
PSU (New and it is the correct required power 600W (maybe even more than I need tbh)): Thermaltake Smart 600W
 
Is my motherboard dead
if this board doesn't include a POST/error code display possibly you could connect an internal speaker for beep codes?

i would remove the board from the chassis and setup a basic breadboard.
if there is still no response from the system other than aesthetic LEDs i would consider that the motherboard has malfunctioned.
though it was just a dead PSU
a "dead" power supply would provide no power whatsoever so no LEDs would light up.
 

ASK THE COMMUNITY