• Enter here for a chance to win a custom MechWarrior 5: Mercenaries themed PC powered by Intel!

Question New PSU worked yesterday, can't start PC today ?

May 10, 2021
1
0
10
0
Hi everyone!

Yesterday I updated upgraded my PSU for a new one with more W. I had a small issue where it wouldn't boot but after replugging a few of the cables it worked perfectly for the whole day. I shut down and restarted the PC multiple times and it was always working without a hitch.

Last night, I shut it down, turned off the power extension it's plugged into and went to bed, and this morning, I was unable to turn it back on. It's just completely unresponsive and if I plug in any of my USB peripherals they don't get powered either. I have no idea what happened since I literally didn't change anything. I tried replugging every single cable again, but nothing happens when I turn on the power.

Tried with the old PSU and now that's not working either. Tried the paperclip method and both the PSUs work fine themselves, but the PC still won't turn on. Also tried jump starting the PC through the power pins. Took out the CMOS battery and put it back in, took out the GPU, reseated the RAM. Tried powering it on with no peripherals connected. Nothing works.

Again I have no idea where to even start. Is there any way to check if something's up with the MB, or the CPU? Just figuring out the bottleneck would be really helpful. I'm really at the end of my rope here cause I don't even know what else to do and all my stuff is on this PC. I suspect the MB may have been shorted (if I haven't forgotten something but as I said it worked with the same cabling yesterday) but I'm not sure how to confirm this, and I'm not really sure why it would happen overnight. Please help if you have any recommendations.

System:
PSU: Argus APS 620W
MB: AsRock G41M-VS3
CPU: Core 2 Quad
GPU: 9800 GT
 

ASK THE COMMUNITY