Question New ram no display

Oct 13, 2019
6
0
10
0
Hello guys.
So I bought some new ram sticks, identical to my current ones, to upgrade from 8gb to 16. I installed both new sticks and my pc would turn off and on. I removed both new sticks and it would boot up as per usual. I tried 1 at a time and it would do turn off and on again.
I assumed the new sticks were buggered so I replaced slot 1 of my original stick with a new one to see if it's the sticks that are buggered, but when I have put the original stick in, the pc starts up but I now have no display. I know it can take up to 31gb, and have them pushed in far enough as they click at each end, the original sticks are both back in and I still have no display.
Please help me, I have just finished installing the new modern warfare and want to play!!
 
Hello guys.
So I bought some new ram sticks, identical to my current ones, to upgrade from 8gb to 16. I installed both new sticks and my pc would turn off and on. I removed both new sticks and it would boot up as per usual. I tried 1 at a time and it would do turn off and on again.
I assumed the new sticks were buggered so I replaced slot 1 of my original stick with a new one to see if it's the sticks that are buggered, but when I have put the original stick in, the pc starts up but I now have no display. I know it can take up to 31gb, and have them pushed in far enough as they click at each end, the original sticks are both back in and I still have no display.
Please help me, I have just finished installing the new modern warfare and want to play!!
Did you rest CMOS/BIOS ?
 
Oct 13, 2019
6
0
10
0
Did you unplug the PC and drain the power off before changing the ram? When you removed the Battery did you unplug the PC or turn the switch of on the power supply?
Yes I did, i left them both around 10 minutes before re connecting. I tried it at a mates house last night and the same thing happened. I have a 600w power supply, he could only suggest it may not be enough to run all 4 sticks. When the display cord is plugged direct into the motherboard it works, but not whwn in the gpu.
 

ASK THE COMMUNITY

TRENDING THREADS