Question New ram resulted in monitor not turning on.

Aug 25, 2019
3
0
10
0
Problem started last night. Took delivery of 2 new ram modules that I ordered. The product was 2x 8GB Corsair Vengenace Rgb pro 2666mhz.
I installed the ram and took my old one out , done this many times without any issues however this time upon attempting to boot up my PC I did encounter one. After pressing power everything seemed normal PC turned on and even the rgb on the ram lit up however my monitor remained off and so did the peripherals on my desk. I immediately started troubleshooting and got onto the forums which told me a variety of things. I tested each ram slot to see if they worked and they did every single one booted up with a single stick of my old ram however if I put my new one in, nothing . I took the CMOS battery out and waited 30 minutes then inserted it again , nothing. I finally took the new ram thinking it was faulty and decided to put it in my dads computer downstairs ( x470 ultra gaming board) and the system booted up without a problem. I've honetsly run out of options and have no idea what to do , I've tried everything I could possibly find and it has not helped.

My system:
I5-8600K
RTX-2070
STRIX Z370-E GAMING
X42 KRAKEN CPU COOLER
Old ram way vengeance lpx 2x8gb 2400mhz
New purchases ram is corsair vengenace rgb pro 2x8 gb 2666mhz
970 pro m.2
Corsair RM650 psu
 

Lutfij

Titan
Moderator
While on the single stick of ram, see if you can set everything to defaults, if there was any manual setting for an overclock on the rams(X.M.P). Can you post back with the version of BIOS your motherboard is currently on? If you have updates pending for the BIOS, go through them gradually then update the chipset/MEI drivers.

Which version of Windows 10 are you on?
 
Aug 25, 2019
3
0
10
0
All changes have been reset to default in bios,XMP is also disabled. Yesterday as a final resort I updated my BIOS to the newest build as I still had a version from 2017. My bios currently is from 12/07/2019 and my windows version is 10.0.16299.
 
Aug 25, 2019
3
0
10
0
While on the single stick of ram, see if you can set everything to defaults, if there was any manual setting for an overclock on the rams(X.M.P). Can you post back with the version of BIOS your motherboard is currently on? If you have updates pending for the BIOS, go through them gradually then update the chipset/MEI drivers.

Which version of Windows 10 are you on?
Right so I updated my Chipset drivers and nothing has helped , I updated my windows from 10.0.16299 to 10.0.17134 and yet again no change. The system still turns on normally however i get no response from my monitor or peripherals. I checked the RAMS compatibility with my MB as well and there should not be a problem.
BIOS version is 2401 Dated 12/07/2019
 
Last edited:

ASK THE COMMUNITY

TRENDING THREADS