• Now's your chance win big! Join our community and get entered to win a RTX 2060 GPU, plus more! Join here.

    Pi Cast Episode 3 streams live on Tuesday, August 4th at 2:30 pm ET (7:30 PM BST). Watch live right here!

    Catch Scharon on the Tom's Hardware Show live on Thursday, August 6th at 2:00 pm ET (7:00 PM BST). Click here!

Question New RAM wont boot into bios , black screen only

Jun 11, 2020
3
0
10
0
Hello guys,

I've upgraded my pc RAM from Geil Pristine Series DDR4 (4GB) to HyperX Fury DDR4 (8GB). It was worked fine on old RAM and on new RAM wont boot at all only black screen. I tested new RAM on my friends pc, its just working fine. Cleared CMOS by put the jumper and remove the battery, and put on the battery again - nothing happened.

My pc spec
CPU: Ryzen 3 2200G
MB : Asrock A320M-HDV R4.0
BIOS: P2.30
RAM: 1x8GB HyperX Fury DDR4 2666 (NEW - HX426C16FR2/8 )
RAM: 1x4GB Geil Pristine Series DDR4 2666 (OLD - GAP44GB2666C19SC )
GPU: Zotac GTX1650 4GB DDR6
Storage: 1TB HDD 7200RPM
PSU: Armaggeddon Voltron Pro 275X 550W

Can somebody point out whats wrong here? Need guidance. Thanks.
 
Last edited:
Ram is sold in kits for a reason.
A motherboard must manage all the ram using the same specs of voltage, cas and speed.
The internal workings are designed for the capacity of the kit.
Ram from the same vendor and part number can be made up of differing manufacturing components over time.
Some motherboards, can be very sensitive to this.

My suggestion is to return the 8gb stick and buy a 2 x 8gb kit that is supported by your motherboard.

If your motherboard bios permits, you can try increasing the ram voltage from the default 1.2v to a higher number.
Sometimes that works.
 
Jun 11, 2020
3
0
10
0
Ram is sold in kits for a reason.
A motherboard must manage all the ram using the same specs of voltage, cas and speed.
The internal workings are designed for the capacity of the kit.
Ram from the same vendor and part number can be made up of differing manufacturing components over time.
Some motherboards, can be very sensitive to this.

My suggestion is to return the 8gb stick and buy a 2 x 8gb kit that is supported by your motherboard.

If your motherboard bios permits, you can try increasing the ram voltage from the default 1.2v to a higher number.
Sometimes that works.
increased 0.05+ now its just turn on and off itself loop but old ram working fine. i give a try with compatible kit.
 

ASK THE COMMUNITY