[SOLVED] New Rpi 4 ,Very Sluggish and slow

Led zeppelin blues

Honorable
Mar 8, 2015
158
4
10,595
2
Hello ,i just got my new Pi 4 (4GB) combo delivered today and using the Pi imager i installed raspberry pi os desktop environment 32 bit

And its extremely sluggish and slow ,chromium take a sluggish approach to open ,the apt update is done so slow and just the whole reponsiveness is very-very sluggish and slow

Browsing is extremely slow and youtube for that matter lags too much

To recap everything ,the whole thing feels slow and this is my first pi and i am a noob and i honestly dont know what i can do to diagnose

ran this and this came - vcgencmd get_throttled throttled=0x0

Could it be a fake poor performing SD Card i got with the combo thats making it run as such ?

Its a Sandisk Ultra 32GB and its 5.30 am here and im sitting quite disappointed not knowing whats wrong because i heard the Pi 4 should be smooth enough right

Any help you can guide me with i would really appreciate it please

Thanks
 

kanewolf

Titan
Moderator
Hello ,i just got my new Pi 4 (4GB) combo delivered today and using the Pi imager i installed raspberry pi os desktop environment 32 bit

And its extremely sluggish and slow ,chromium take a sluggish approach to open ,the apt update is done so slow and just the whole reponsiveness is very-very sluggish and slow

Browsing is extremely slow and youtube for that matter lags too much

To recap everything ,the whole thing feels slow and this is my first pi and i am a noob and i honestly dont know what i can do to diagnose

ran this and this came - vcgencmd get_throttled throttled=0x0

Could it be a fake poor performing SD Card i got with the combo thats making it run as such ?

Its a Sandisk Ultra 32GB and its 5.30 am here and im sitting quite disappointed not knowing whats wrong because i heard the Pi 4 should be smooth enough right

Any help you can guide me with i would really appreciate it please

Thanks
There is a disk performance tool included with the OS. Test your card. I recommend switching to a USB adapter with an SSD. 10X performance over SD card.
 
Jun 19, 2021
3
1
15
0
Did you get the official power supply? Sounds like its being underpowered...also dont use the built in Wifi, it pretty much sucks.
 

mamasan2000

Distinguished
SD card performance is somewhere around 30-50 megabytes/s. The non-fake, OK? That is 3-5 times SLOWER than a normal spinning rust harddisk! Are you expecting miracles?
2nd of all, use an ethernet cable, wifi sucks, always. Unless you sit on your router. Then it's almost decent.
 

ASK THE COMMUNITY