Question New Ryzen 2700 system wont POST .

Alextg

Distinguished
Sep 3, 2012
7
0
18,510
0
Hi guys, I come to you totally desperate. I just built a new pc with the following specs:

Ryzen 7 2700
MSI B450m Vdh pro max
Corsair Vengeance LPX 3000
SSD Crucial MX500
Evga Bq 600 w
Nvidia gtx 1070

All components are brand new and purchased from Amazon. (With the exception of the gpu that was bought a couple of years ago)

I built the system carefully (I have already built many pcs) so I am sure I have done it well. But pc wont post. I have tried everything, including the guide that is posted in this same forum, but nothing. I'm sure the PSU is working perfectly. I tried it on other computers. So the culprits must be Cpu, ram or Mobo.

I also tried to swap parts with another pc that I have in my work: Ryzen 7 1700, B350f (latest bios update) corsair lpx 3200 bdie type. Here's what happen:

New R7 2700 on B350-F: not POST (vga debug led on board, but 1070 is correctly installed and working on other systems )
Old R7 1700 on MSI B450 : System dont POST (ram debug led on)
New LPX on B350f with 1700: not POST
Old LPX (bdie) on B450 with 1700 or 2700: not POST (cpu debug led on)

So as you can see, none of the new parts work, even on the other PC that is fully funcional. Could someone give me an idea of what to do? Can it be possible that all new parts are defective? A short or something similar can ruin all the components that way? Please help me.
 

ASK THE COMMUNITY

TRENDING THREADS