Question New ryzen 3 2200g build doesn't send a video output...

Dec 8, 2019
8
0
10
0
I'm very new to pc building and I have recently bought a couple of pc parts during black friday. Today, my parts arrived, and I was very excited to put my pc together. I decided to test it outside of the case before hand, but it wouldn't send a video output. I've tried booting up wjth one ram stick, with a video card, ive also tried removing the cmos battery, but nothing is working. please help me fix this issue.

Cpu: ryzen 3 2200g
Motherboard: Asrock b450m hdv
Ram: Corsair vengeance lpx 2x8gb 3000mhz cl15
GPU: xfx rx580 8gb
Psu: Thermaltake smart rgb pro 600w 80+
Storage: 2tb seagate barracuda hdd + 256gb wd green ssd
case: Thermaltake h17 matx
 

Wolfshadw

Titan
Moderator
motherboard may needs Bios Updated
CPU Support List - ASRock B450M-HDV
The motherboard does not need a BIOS update as the 2200G processor is natively supported.

I'm very new to pc building and I have recently bought a couple of pc parts during black friday. Today, my parts arrived, and I was very excited to put my pc together. I decided to test it outside of the case before hand, but it wouldn't send a video output. I've tried booting up wjth one ram stick, with a video card, ive also tried removing the cmos battery, but nothing is working. please help me fix this issue.

Cpu: ryzen 3 2200g
Motherboard: Asrock b450m hdv
Ram: Corsair vengeance lpx 2x8gb 3000mhz cl15
GPU: xfx rx580 8gb
Psu: Thermaltake smart rgb pro 600w 80+
Storage: 2tb seagate barracuda hdd + 256gb wd green ssd
case: Thermaltake h17 matx
In many cases, the on-board graphics are disabled if a discrete graphics card is detected. Are you connecting your display to the graphics card (RX 580) output or the motherboard graphics output? It should be connected to the graphics card.

If the intent is to use both, there may be an option in the motherboard BIOS in which you can enable the on-board graphics while a discrete graphics card is installed, but this should not be needed.

-Wolf sends
 
Dec 8, 2019
8
0
10
0
ive tried plugging my cable into the graphics card as well. Nevermind, though, because i managed to boot up by clearing the cmos, removing all the parts, reinstalling them, and turning the pc on. Thank you all for the help, though.
 
Dec 8, 2019
8
0
10
0
ive tried plugging my cable into the graphics card as well. Nevermind, though, because i managed to boot up by clearing the cmos, removing all the parts, reinstalling them, and turning the pc on. Thank you all for the help, though.
im not sure why it worked after clearing the cmos for the second time, but it did
 

ASK THE COMMUNITY

TRENDING THREADS