New Sapphire HD 4870 Causing Slow Minimizing


Jan 8, 2009
Alright, i'm at wits end on this one and this is something that will ultimately determine whether or not I keep the card. First, here's some basic system specs -

Intel Q6600 Quad-core Processor
Asus P5E Motherboard
4GB Corsair Dominator 4-4-12 RAM
Sapphire HD 4870 1GB
Windows XP Pro 32-bit

I went from using an old Geforce 7950 GT. Since i've upgraded a couple of things have happened. After putting the card in I noticed three new entires appear in my Other Devices section of Device Manager. Two "PCI Device" entries which I have no idea what those might be nor if they are causing any problems, and also my SM Bus Driver had to be reinstalled from the chipset drivers for some reason, which I did.

The main problem is that whenever I minimize a game running at full screen it takes a good 2-3 seconds to complete the task and also as I was told by some people on Ventrilo, if i'm talking when I do it my voice cuts out until it's done. My mouse cursor also freezes up for a second or two. Everything on my much older nvidia 7950 GT was instant with no delays. The main game I notice it in is WoW; however, I tested it with Warcraft 3 and it does the same. Other than that I don't really have many 3D games installed since I just finally upgraded.

I've tried reinstalling the drivers from multiple sites (Sapphire's Site, ATI's site, the disc itself) which hasn't helped. I installed the latest DirectX just to be sure, but that hasn't helped at all either. I've looked through most of the options in the Catalyst control center; however, the things i've tried checking and unchecking haven't helped either, although there is a lot of stuff in there that i'm not entirely sure what it does.

The card itself runs great when i'm in WoW so I really am liking the card itself but this staggering slowdown whenever I need to multitask is just getting irritating. I googled the problem and could find little about it, so if anyone has any input on this it would be greatly appreciated or I may end up filling out an RMA form =(


Feb 4, 2009
I have the exact same problem. Thought I'd let you know, so you know it's not just your system. My situation is almost identical: I just bought an ASUS 4870 x2, upgrade from an nVidia 7800 GT. I play WoW and it takes 2-6 seconds to fully minimize and I have the same Ventrilo problem. My specs:

AMD 6000+ dual core
Windows XP Home (32-bit :( )

I've tried AMD 9.1 drivers and 8.10 drivers. Neither fix the problem. I used driver cleaner to clean uninstall all nVidia drivers (and ATI drivers when I was switching between 9.1 and 8.10).

A possible solution to your case, since you didn't mention this, is making sure your game's resolution and refresh rate are the same as your desktop's. This is the normal reason for black screens during minimizing. However, if you're like me and are aware of this, you've probably already checked. My temporary solution has been to run WoW in maximized windowed mode.

Anyway, like Kuradoberi said, this is a very serious and annoying issue and anyone who can offer a solution, please do so ASAP.


Same problem here, although Im using a HD 4850. The similarities are exactly the same, right down to having to reinstall my SM bus drivers.
Not sure if they're related but I've also had some problems with Civ4 and Guitar Hero 3, basically they will skip frames during movement, for example, whilst scrolling across the map on Civ4 and whilst the fret board is going down on GH3 a frame will skip every 2-4 seconds, however if I turn the resolution down and then back up to 1280x1024 the problem will go (in both games) until the next day when I turn my PC back on.

Similar threads