New SATA HDD not found in Windows - Seen in BIOS

cptrainer01

Distinguished
Apr 9, 2008
4
0
18,510
0
I have an existing SATA 2 HDD in my system. I just bought a Samsung 200GB SERIAL ATA HD 7200/8MB/SATA-3G HDD which I assume is also SATA 2 based off the throughput speed. It is recognized in BIOS, but not in windows. Does anyone know what is going on? Does it matter if I mistakenly go a non SATA 2 HDD, w/ a MOBO that is designed for SATA 2. Even though BIOS sees it? I don't think it's the SATA controller drivers cause my other SATA HDD is detected just fine. I always check DM after installing my OS which I did a while back.
 

drkw

Distinguished
Mar 15, 2008
3
0
18,510
0
Look for the drive using Partition Magic or similar, and check the partitioning and format.
 

dagger

Splendid
Mar 23, 2008
5,624
0
25,780
0


You don't need third party software, go to administrative tools -> disk management.
 

Darron

Distinguished
Apr 7, 2008
24
0
18,510
0
As dagger said:
Go to administrative tools -> disk management.

Then you need to format it before you can use it and thus see it in windows.

SATA2 controller on you MB will function just fine using a SATA "1", so don't worry about that :)
 

cptrainer01

Distinguished
Apr 9, 2008
4
0
18,510
0
Ok well...I went to disk management 2 times, after double checking my cabling and that BIOS detected it. The only things that come up are my old SATA HDD and my DVD drive.
 
Is the SATA controller that your new drive plugged into set to SATA (or legacy or some such) or is it set to AHCI (aka NCQ)? If it's set to AHCI, Windows needs drivers (F6 at Windows install) to see the drive in AHCI mode. If this is the case just set the controller to SATA, then Windows should see it. I guess I am assuming Windows XP, since I believe that Windows Fista supports AHCI without install time drivers.
 

cptrainer01

Distinguished
Apr 9, 2008
4
0
18,510
0
I'll check that out tech geek, and _visual I don't have another machine to test it on. I'll let you know how it went once I get home.
 

cptrainer01

Distinguished
Apr 9, 2008
4
0
18,510
0


Do I change that in BIOS cause I was f***ing around in there and didn't see a way to change that, but then again I was just verifying that it was seen and nothing else. Windows XP is already happily installed on my system so If I have to do this only during the Windows install no can do.
 

Preecher

Distinguished
Jan 10, 2006
280
0
18,810
24
Did you enable the drive in the BIOS? One of my comps is an older dell and I added a new SATA drive but it didnt show in windows. I had to go back into the bios, select the drives option and then go to SATA 2 (I have sata 0 though 4, for some reason it was under 2 and not 1 as I would have suspected) and actually turn it on (Meaning that port was disabled).
Good Luck
 

Similar threads


ASK THE COMMUNITY