Question New SSD(s) not detected in Windows or BIOS, but other weird stuff too...

Sep 3, 2020
2
0
10
0
Hi all, I've searched through a lot of similar threads on SSDs not booting/being detected but I think my issue is slightly different for weird reasons.

Background: I have an SSD and HDD installed and wanted to add a new 500gb SSD to this setup.

Bought a Kingston, plugged it in, tried power on - fans spin for half a second and then everything stops. PC simply won't power up with the new SSD plugged in alongside the existing storage. I tried using new/different power and data cables, using different slots but the same thing every time. Thinking it might be a PSU thing, I unplugged the HDD and tried again - PC does power on, but new SSD isn't detected anywhere in bios or Windows. Assumed DOA, returned, bought a Samsung...

...but exactly the same thing is happening with this second new SSD. With all three drives, no power; with just two (or even just the new SSD on its own), it's not detected at all. Again I've tried all different combinations of cables and slots (including trying just the SSD with cables that already work with my current drives) and nothing. I've spent hours in bios settings, flashed it, tried all the different start up/compatibility modes and I'm completely stumped. Am I missing some deep buried secret of SSDs or bios, or have I just been drastically unlucky with two DOA SSDs? Thanks for any tips/advice.

Tech detail:

i5 4970k, 8gb DDR3, Asus z97p mobo, 650w PSU. Current SSD is a Kingston A400 240gb, HDD is a Western Digital 10EZEX 1tb. First new SSD was also a Kingston A400 but 480gb, second attempt is a Samsung 860 Evo 480gb.
 
Last edited:

ASK THE COMMUNITY