New stirX GTX 1050 Ti won`t work

jacksoftware

Prominent
Oct 24, 2017
1
0
510
0
Hello
I bought new GTX 1050 Ti but when I installed and turn on the pc it just work for less than a second and the LED turns to blinking and fans stop working and monitor says it receive no signals not even black.
my motherboard is asus p8p67 le it has pcie x16 version 2.0 but the graphic card is 3.0
so is this the problem or what?
tnx
i correctly connected the 6 pin power for it and the psu is 450 wat so all im asking is these two compatible or not
and could you tell me about the LED meaning on this card the user manual says nothing and what is it mean if it slowly blinking
 
Check your MB BIOS version, if it does not have the newer one, 3801 version, then update the BIOS fisrt, then try use the gtx1050ti again. https://www.asus.com/Motherboards/P8P67_LE/HelpDesk_Download/

For the LED light, you should check your MB manual, you will know from it. https://www.asus.com/Motherboards/P8P67_LE/HelpDesk_Manual/
 
Check your MB BIOS version, if it does not have the newer one, 3801 version, then update the BIOS fisrt, then try use the gtx1050ti again. https://www.asus.com/Motherboards/P8P67_LE/HelpDesk_Download/

For the LED light, you should check your MB manual, you will know from it. https://www.asus.com/Motherboards/P8P67_LE/HelpDesk_Manual/
 

ciki69

Prominent
Oct 24, 2017
2
0
510
0
Hi.
There is 1 more thing. Check the bios witch PCI-e lane is running. Maybe because of the plug in out your MBO decided to switch lanes. PCI-e 3.0 is backwards compatible to MBO 2.0 and it should work just fine, if that does not help than flash the bios :)
 

ASK THE COMMUNITY