Question New System Build No Display

Jan 20, 2022
3
0
10
0
Have installed the following:
MPG X570 Gaming Plus, AMD Ryzen 5 5600 X 6, GeForce RTX 3070, 2 Ballistix 16 Gig SDRAM, EVGA 750 G5.

Note this is the PC listed as the best one to build by Tom's Hardware for 2022 for January. At least this was true when I bought the parts.

Just had the CPU replaced due to it not showing up as working per the motherboard. New Chip shows the same issue.

Pulled the battery out to reset the BIOS, but have the same issue. Not sure what the next step would be.

I've don't this stuff in the past, but it's been a long time. Any support would be great.

By the way, the Video Card cable is totally fine. Works on another machine. Using the HDMI Cable. No issues with it.

Also have an M2 card in as well.

I just read through from the ReadMe's above on how to fix issues with a computer that is not working. Seems I have done those items.
 
Last edited:
Have installed the following:
MPG X570 Gaming Plus, AMD Ryzen 5 5600 X 6, GeForce RTX 3070, 2 Ballistix 16 Gig SDRAM, EVGA 750 G5.

Note this is the PC listed as the best one to build by Tom's Hardware for 2022 for January. At least this was true when I bought the parts.

Just had the CPU replaced due to it not showing up as working per the motherboard. New Chip shows the same issue.

Pulled the battery out to reset the BIOS, but have the same issue. Not sure what the next step would be.

I've don't this stuff in the past, but it's been a long time. Any support would be great.

By the way, the Video Card cable is totally fine. Works on another machine. Using the HDMI Cable. No issues with it.

Also have an M2 card in as well.

I just read through from the ReadMe's above on how to fix issues with a computer that is not working. Seems I have done those items.
Have you tried to update the bios via usb flashback?
 

ASK THE COMMUNITY

TRENDING THREADS