Question New system cannot boot from any device listed in boot device list ?


Apr 2, 2018
Hey everyone, I'm on my last leg here and decided to make a post here as a last ditch effort.

I have just built a new system, part list here:

My new system can boot into BIOS and sees ONLY my flash drive containing Windows installation. (Rufus installation GPT/UEFI)
If I enable CSM support, I see my M.2 drive and another instance of my flash drive in the boot order list.

Attempting to boot from any of these devices results in failure (a solid underscore frozen screen until I manually restart the PC)

One thing of note is that any post on the internet explaining any similar issue describes this as a blinking cursor/underscore. Mine is not blinking. I get one frame of blink and then it turns solid, indicating some sort of stoppage.

Thus, the issue at hand is that this system cannot boot from any bootable devices.

I'm unsure how to proceed. I have already replaced the motherboard (bought another one and sent the old one back, as a faulty motherboard was the most reasonable reason), I have tried every combination of system parts I can (RAM combos, SSD in/out, GPU in/out), and I simply cannot update the BIOS without another freeze occuring.

Here are the list of remedies I have attempted:

  • I have tried reinstalling the flash drive with Windows 10 three times, Windows 11 once.
  • I have tried reinstalling the flash drive with Windows 10 using another PC.
  • I have also tried a Master Boot Record Windows installation and a GPT Windows Installation (for the newer UEFI) using Rufus USB.
  • I have tried all 12 USB ports on the new system for USB installation.
  • I have tried booting from the flash drive on 3 other machines - I'm able to install Windows to all of them.
  • I am able to see all files on the USB in the BIOS, so I know the system can see the contents of the flash drive.
  • I have tried starting the PC with 1 RAM dimm, no GPU, swapped RAM dimms, no SSD, a different SSD, etc.
  • I have made sure the SSD works in another system.
  • I have pre-installed Windows 10 onto the M.2 drive using another PC.
  • I have tried updating the BIOS, it freezes when I attempt to press the "Ready to Restart" button, resulting in keeping the same BIOS version when manually restarted.
I have not attempted using a different USB stick because I don't have easy access to another. However, like previously stated, the USB works in other machines and is detected in the new one, so I'm not sure how likely it is for this to be the problem.

Any advice would be greatly appreciated because I'm currently stuck with a very rainbow paperweight.