Question New Tomahawk X570 not posting with new Ryzen 5600X - hope this helps people

Sep 7, 2021
Hey all, just posting this to try and help some people as it's a unique issue I've had.

Quick note: I have one more step to try, which is trying a Ryzen 3600 CPU that I have - to isolate this issue to the CPU or Motherboard.

Trying to boot a Ryzen 5600X with an MSI Tomahawk X570 motherboard. Issues and order of them are below:

With all parts in place, booting up shows the following Debug LED's: BOOT, VGA and CPU (DRAM is Off). Tried just one RAM stick in the 2nd slot (Was using slots 2 and 4 as per recommendation for 2 sticks). Trying to remove GPU and RAM had the same result.

I tried flashing the BIOS, which appeared to be working as the LED at the back of the motherboard flashed for 5-6 minutes. But then the PC didn't reboot as it should. In some cases I waited up to 30 minutes.

I did a CMOS reset, which showed the following Debug LED result: BOOT, VGA and DRAM On. CPU Off.

Long story short I then removed all parts from the motherboard, including the CPU. I left only the 24-pin motherboard and 8-pin CPU power supply cables in.
I was then able to successfully complete a BIOS update, as the PC did restart this time. On booting up, ONLY THE CPU Debug LED was on. (Which made sense)

As soon as I put the CPU back in, I get the following LED Debug lights: BOOT, VGA and CPU. DRAM was Off.

I also had several instances where resetting the CMOS would result in the Debug LED's randomly interchanging their pattern, but always having 2 or 3 lights on. Not consistent at all.

My final step is to try my Ryzen 3600 CPU in the motherboard, to isolate this issue to the 5600X CPU or the motherboard. I can't do this for a couple of days as I need to wait for thermal paste to come in the mail.

Would be cool if it were possible to get into the Bios without needing a CPU. Alas we need to take these steps.
Last edited:
Sep 7, 2021
Which BIOS version did you update to, V14 or V17?
Do you know what Stepping version your CPU is (B0 or B2)?
Did you ever reinstall the graphics card once the BIOS (supposedly) successfully updated?

-Wolf sends

Also, can you confirm this is your motherboard: MSI MAG X570 Tomahawk WiFi
Hey, thanks for the questions.

Yes, that's the correct motherboard. Here you go:

  1. So I tried two different versions when it appeared I was getting successful Bios updates after removing all components: V17 and then V16. (Constant flashing for 4-5 minutes followed by a complete auto reboot at completion).
  2. Stepping version - I'm not sure how to check that - any suggestions? (Google didn't say much about how to determine) - (UPDATE: Okay I think I can see what you're getting at. Maybe I need to try V14 BIOS update as it could be a B0 chip?)
  3. Yes, I tried a variety of components. Including CPU, RAM and GPU in sockets. Also no RAM, no GPU etc. to try and get a variety of Debug LED errors. This was attempted after the BIOS appeared to successfully update.
  4. I've also tried another known good working PSU to rule out that as an issue. Issues are identical depending on status of CPU in or out.
Note: I've also done a thorough check on the physical health of the CPU pins, and the Motherboard CPU slot. Appear to be no damage or foreign substances anywhere.
Also the RAM and GPU are always 'active' when plugged in (both have RGB).

GPU: MSI 6600 XT Gaming X RGB
RAM: Corsair Vengeance Pro SL (2 x 8 GB - 3200 Mhz)

Question: Is it possible to do a quick test with a CPU in without the cooler on top? The messy part is the placement then removal of the cooler. during troubleshooting I then have to delicately clean around the CPU chip so thermal paste doesn't leak down. Painstaking stuff as we all know.
Last edited: