Arbiter051

Honorable
Mar 28, 2016
255
2
10,795
0
Hi there, I tried to update windows today and after successful installation of the new update. My monitors starting flickering after logging in. The desktop and taskbar are blank and the screen just flickers constantly.

I tried booting into safe mode to clean out my gpu driver, but the flickering is happening there as well. Anyone else experiencing this issue? Ty

9900kf
Gtx 970 (not the latest driver, I have the one released in may)
Z390 aorus pro with latest bios
 

Lutfij

Titan
Moderator
Source the latest driver for your Nvidia GPU from Nvidia's support site. Then use DDU to uninstall your GPU drivers,. reboot, reinstall said GPU drivers with the latest driver version(sourced prior) in an elevated command, i.e, Right click installer>Run as Administrator.

Make and model of your PSU and it's age?
 

Arbiter051

Honorable
Mar 28, 2016
255
2
10,795
0
Source the latest driver for your Nvidia GPU from Nvidia's support site. Then use DDU to uninstall your GPU drivers,. reboot, reinstall said GPU drivers with the latest driver version(sourced prior) in an elevated command, i.e, Right click installer>Run as Administrator.

Make and model of your PSU and it's age?
Sorry forgot to say the PSU. Corsair rmx850 gold. System except for gpu is 3 years old in Augean.

you are saying I should update my gpu drivers before installing the windows update? Safe mode doesn’t work either after this particular update.

what I am wondering is that if I have the problem in safe mode, that should rule out my gpu driver being the problem shouldn’t it? Forgive me if that sounds dumb.
 
Last edited:

Arbiter051

Honorable
Mar 28, 2016
255
2
10,795
0
I’m sorry if this isn’t allowed but just a follow up. I tried updating again and even installing 21h1. Problem still happens, I then also tried ending windows explorer which resulted in a black screen with the taskbar not flashing any more as I expected.

I then restarted it and the flashing/constant refreshing came back. I tried uninstalling the update through uninstall latest consultative update (from the blue troubleshooting screen) and nothing happened. Tried doing the feature one and it said it can’t and to reset my pc…

mind you this is happening in safe mode as well where my video drivers, antivirus and whatever else is not being loaded (please correct me if I am wrong).

idk what this update did, but it seems to be extremely broken. Thankfully I have backups so I backed up to an earlier system image and I’m fine for now.

can anyone she’s some light on this or is this happening to anyone else? If it is I am sorry but know you are not alone.
 

ASK THE COMMUNITY