Newly built computer won't turn on after mb update

Aug 28, 2018
So, I just built a computer for the first time. I thought everything was going really well. I was able to install windows, VLC and chrome before I went to put in the disk that came with my mb. It asked me to restart after it finished and I did. After it booted again I turned it off to add another stick of ram and it hasn't been able to turn on since then.
My setup:
Asus prime z370-a
Intel i7-8700k
2x8gb trident z f4-3200c14d
Corsair h100i V2
Gtx 1080ti MSI gaming X twin frozr vi
Evga 750 P2
Evo 970 500gb

I have tried unplugging and replying everything. I have tried using just the one stick of ram, I have tried the ram in different slots. I have tried to use the power switch on the mb and I have tried to use a screwdriver to connect the power switch pins. I have gone through this whole list
I don't have another desktop to switch parts easily and test what is going wrong, when I tried bread boarding the machine I couldn't get any fans to spin up or signal to my monitor. It seemed the same as when I had it in. The motherboard would light up but that was it.
When the PSU is switched on the RGB on the motherboard will turn on as well as the power light, nothing else is lit. There is a click coming from the PSU when I press the power button. But nothing else.

So I am getting a fault error with my PSU. Replacement will be here Friday and I will update this then.

So new PSU came in, I installed it and everything is working well. Super excited to play some games.


Glad you got the system working again. It's also a good example you've shown by following through all possible suggestions in order to come to the conclusion that the PSU was at fault. In case you suffer a similar situation, you can also try and remove the CMOS battery and replace it after 15 minutes, often times installers or the BIOS may be corrupt resulting in a no boot issue.