Question Newly built PC just shut off mid-Windows install.

Feb 17, 2020
6
0
10
0
So the PC I just finished building just shut down abruptly while installing windows and now it won't turn on no matter what I try. The RGB lights and board lights themselves light up, but neither the case's power button, nor the mobo's built-in power button do anything when I press them. Any ideas? It worked fine for a good 15-20 minutes and even trying to turn it on hours later won't do anything.

CPU: Ryzen 3900x
CPU: NZXT KRAKEN X72
Motherboard: ASUS AM4 X570 ROG Crosshair Hero VIII
RAM: 64GB G-Skill Trident Z Neo DDR4 3600
PSU: Seasonic SS-1050XP3 1050W
SSD: Corsair MP600 Nvme
Case: Lian Li Lancool II
Case Fans: Lian Li Bora Lite 120 x5
 
Last edited:
Feb 17, 2020
6
0
10
0
Please provide full pc spec including make and model of psu.


CPU: Ryzen 3900x
CPU: NZXT KRAKEN X72
Motherboard: ASUS AM4 X570 ROG Crosshair Hero VIII
RAM: 64GB G-Skill Trident Z Neo DDR4 3600
PSU: Seasonic SS-1050XP3 1050W
SSD: Corsair MP600 1TB Nvme
Case: Lian Li Lancool II
Case Fans: Lian Li Bora Lite 120 x5
 
Feb 17, 2020
6
0
10
0
Nice build.

I would guess you have already gone in and checked all power supply to hardware connections, reseated the RAM, etc?
I was hoping it was an issue with the cables, but i've re-seated everything and it's still doing the same thing. I'm legitimately out of ideas as to what it might outside of a MOBO or PSU issue. The MOBO LEDs light up so there's some power going to it from the PSU, but it straight up dies not post, it's basically dead.

I tried swapping PSUs with another computer I built and curiously the older PSU did not work on the new PC., while the new PSU did not work on the old PC.
 

ASK THE COMMUNITY

TRENDING THREADS

Latest posts