Newly built PC not even posting

Mealstrom

Prominent
Jul 20, 2017
3
0
510
0
Well, this has been fun. I got a gigabyte gaming 3 and a ryzen 1600 without knowing the bios needed to be updated to even get it to boot. Well, that's not the only problem. The motherboard lights won't even come on, despite the fact that it's powering a keyboard and external hard drive when I power it on. I've gone through all the troubleshooting tips already, and tried every one. Right now, it's just sitting, unattached to everything unnecessary, but the MB lights refuse to come on at all. Is it a bad MB? Power supply issue? And is it possible to Qflash the bios without a AMD 7 processor anyway?
Oh, and I have a EVGA SuperNOVA 650 power supply, if you needed to know.
 
You can't do anything with the BIOS without a functioning processor; if you don't know anyone wtih an R7 to experiment with, you could certainly try another known good PSU. but, beyond that, it might be RMA time for the MB...; tell them 'DOA/won't post'
 
Are you sure you have the supplemental AUX CPU power from PSU straight to MB connected too?

https://www.google.co.jp/search?q=PSU+CPU+POWER+connector&rlz=1C1CHZL_enJP736JP736&source=lnms&tbm=isch&sa=X&ved=0ahUKEwi39YXtopfVAhUEzLwKHZxVCfAQ_AUICigB&biw=1088&bih=510#imgrc=7cOiv2t0SQ1sBM:
 
You can't do anything with the BIOS without a functioning processor; if you don't know anyone wtih an R7 to experiment with, you could certainly try another known good PSU. but, beyond that, it might be RMA time for the MB...; tell them 'DOA/won't post'
 

Mealstrom

Prominent
Jul 20, 2017
3
0
510
0
Tried with another PSU and the MB didn't respond either. Any suggestions on a good one to get around that price range so I don't run into compatibility issues again?
 

ASK THE COMMUNITY

TRENDING THREADS