Question newly built pc with no display/post

Nov 25, 2020
3
0
10
0
first time pc builder here, and my specs are

CPU: Ryzen 7 3800x w/ stock cooler
Mobo: MSI MAG x570 tomahawk WIFI
Ram: G.SKILL Ripjaws V Series 16GB (2 x 8GB) 288-Pin DDR4 SDRAM DDR4 3600 (PC4 28800) x2
GPU: PowerColor Red Dragon rx 5700xt
HDD: Seagate BarraCuda 2TB
SSD: Samsung 970 evo plus 500gb
PSU: CoolerMadter MWE 650W
Case NZXT H510

So i put everything together while watching tutorial on youtube. the only note worthy thing for me is that while installing the stock cooler for the cpu, i believe i used unusual amonut of forcevto flick the hook switch over. Other than that i believe i follow the tutorials pretty well.

Fist time turning on the power button, Cpu cooler fan on full blast, MSI EZ debug CPU light stay on solid white. Plug in HDMI and DP to the graphics card. Grahphics card fan not running at all. Nothing. i let it run for a good 30 mins cuz i dont know what it's doing.

After some research online, seem like a common issue with the ram or BIOS not up to date( i know thats with 5000 series, and even that x570 should work out of the box). So i remove all the rams first and leaving one on the slot the manual say to slot in first. Nothing. Solid white CPU ez debug light.

Then i decided to flash the BIOS since the MOBO is telling me there is something wrong with the cpu. After downloading, renaming the file, i use the BIOS flashback button that come with the board to flash it. After what i think its done(cpu fan runnifng the whole time, full blast on first, the it lowers to a normal level), ez devug light finally turns off. and still no gpu fan running, and ofc, no display.

Since i dont have other hardwares with me, i cant do what others do and put in the known good part to eliminate possible DOA. All parts are bought new( beside the HDD, it came with a bubble pouch without any packaging).

What is the reasonale next step.for me to do here?
 

ASK THE COMMUNITY

TRENDING THREADS