No access to public wifi

Status
Not open for further replies.

vipcampbell

Honorable
Feb 19, 2013
1
0
10,510
0
Hello,
I am abel to connect perfectly at home but no longer in public areas such as Starbucks, etc. I do not get the public website to agree to the terms and connections. My laptop tries to connect to my homepage and skips the log on page (ie: Starbucks.com) then freezes and I receive an error message that there is no internet connection. When I go to "Data Sharing Center" it states that I am connected...
Any info welcome.
 

ngrego

Distinguished
Jan 25, 2012
1,119
0
19,660
115
When you select the Starbucks network from the available networks list does your laptop actually connect to the wifi network?
If you check the network icon after you have selected the desired network it should have some kind of indication of your connection status. If you can, check the adapter settings to see if you have been issued an IP address. If you are connected and have an address but still cant connect there may be some kind of security setting blocking your access, possibly an antivirus program or very strict settings. Public networks usualy need to have access to browser cookies, to register devices on their networks also.
Have you tried connecting with an other device like a smart phone or other laptop?
 

mbadge

Honorable
Nov 24, 2013
2
0
10,510
0
I am having the exact same problem. My computer can use my home wifi but not public wifi. It says it connects to the network but has no internet access.
 

TRW1

Reputable
Mar 15, 2014
1
0
4,510
0
I'm using an ASUS laptop with Windows 8 and I have had the same problem not getting to the 'Terms and Acceptance' page at Starbucks. I scoured the internet for a solution. Nothing worked. I stumbled on a possible solution today. (I was able to get to the login page and have been on the internet at Starbucks for 20 minutes without getting kicked off). I use an MSN live login to unlock my computer. Today, before I went to enter my password, I went to the left side of the lock screen and chose connect to a network. I selected the ATTwifi network and waited for the connection. Once my computer was connected to the network, I entered my password to access my computer and have been successfully surfing ... so far.
good luck!!!!
 

bfiscella

Reputable
Dec 4, 2014
1
0
4,510
0
Here's what worked for me after I was unable to find a solution. The reason I couldn't log onto a public wifi page is the "accept terms" page was not popping up.
What I had to do was first connect to the network. Then at that point, hit the start icon on the lower left corner of my computer screen, and in the search box type CMD. When the black box pops up (and where the cursor appears) type IPCONFIG. Then search for the Default Gateway. It will look something like this:

Default Gateway . . . . . . . . 162.121.192.9

Open Internet Explorer (it seemingly will not work with Chrome or any other web browers). In the address page, type in that Default Gateway code (162.121.192.9). Hopefully that will solve your problem.
 

alexpinca

Reputable
Dec 29, 2014
1
0
4,510
0
Here's what worked for me on Win7, IE11...I had the same exact problem...I could see that my computer was connected to the network but it wouldn't deliver the login page...it kept coming up "Web page can not be displayed.". I typed "login" in the address bar...and bingo...I had the login page.
 

denali jones

Reputable
Apr 11, 2015
1
0
4,510
0
■ I had the same problem with a new laptop. If you put "purple.com" into the address window, it should bring you to the welcome screen. I got this fix from the AT&T wifi tech support. Worked to connect both IE and Chrome.
 

Charlene_1

Reputable
Sep 9, 2015
1
0
4,510
0
I am having the same problem in Windows 10 on my tablet. It successfully connects to the open network, but will not display the authentication page. My android phone does connect and allow the "i agree" page, but i can't get Windows 10 to be useful on the same network. I connect, but can't get to the internet because of the browser requirement. Help!
 

baylorgang92

Reputable
Oct 1, 2015
3
0
4,510
0
Just fixed mine by the grace of god, stumbled upon it by noticing a missing file.
for windows
run command prompt as admin
type sfc/scannow
restart computer when finished

mine had been like this for two months with no solution.
Hope this helps someone, felt inclined to share.
 

Aiden_2

Reputable
Dec 6, 2015
1
0
4,510
0
ok just solved it. im using free wifi service on my pc. I share 1.5m of my internet and in exchange i get to connect to others everywhere from the same service. the thing is I need to log in first. the login is a popup on the browser therefore you need to disable the popup blocker both plugin (if you have it ex. adblocker) and in your browser settings. ex. on firefox go to TOOLS/OPTIONS/CONTENT and uncheck BLOCK POPUP WINDOWS.
enjoy
peace from IL
 
Status
Not open for further replies.

TRENDING THREADS