• Now's your chance win big! Join our community and get entered to win a RTX 2060 GPU, plus more! Join here.

    Pi Cast Episode 3 streams live on Tuesday, August 4th at 2:30 pm ET (7:30 PM BST). Watch live right here!

    Catch Scharon on the Tom's Hardware Show live on Thursday, August 6th at 2:00 pm ET (7:00 PM BST). Click here!

Question No bios after GPU switch

Oct 17, 2019
12
0
15
0
I went from a Radeon R9 390 to a RTX 2070 super and i uninstalled AMD software and switched cards. Now my pc doesn't even go to bios with the new or old GPU installed or Igpu i tried that aswell. What did i [censored] up?
 
What is the make/model of your motherboard and processor?
Modern graphics cards need a UEFI bios to run.
But, that would not explain why you can not get into the bios with your old card.
Some monitors do not autodetect the input connection.
Is it possible that you need to use the monitor onboard control to do the selection manually?
How do you get into the bios?
Perhaps your keyboard is not properly connected.

Ultimately, you need to get your old card to display something.
It will have a low res default mode that runs without any drivers at all.
 
Oct 17, 2019
12
0
15
0
What is the make/model of your motherboard and processor?
Modern graphics cards need a UEFI bios to run.
But, that would not explain why you can not get into the bios with your old card.
Some monitors do not autodetect the input connection.
Is it possible that you need to use the monitor onboard control to do the selection manually?
How do you get into the bios?
Perhaps your keyboard is not properly connected.

Ultimately, you need to get your old card to display something.
It will have a low res default mode that runs without any drivers at all.
I have a msi B450 m2 pro with an AmD ryzen 3600.

The monitor detects a displayport input while my other monitor does nothing when plugged in with hdmi i could try switching it around if needed but i don't know if that would do anything.

I don't even get to the press F2 to enter bios or what it says screen its just black with both cards
 

ASK THE COMMUNITY

TRENDING THREADS