Question No display after bios update - 7900XTX/B550

danko12321

Distinguished
Jun 27, 2015
17
0
18,510
B550 5600X 7900XTX
I was running fine enjoying the new card and decided for no good reason (lesson learned..
) to update my bios. Gigabyte Aorus elite.
No longer get display out through the card. System posts and stays up with all the fans and lights on.
Tried flashing bios back to the previous version with q flash plus but it's still not giving a display out via the GPU.
Not sure what to try next. I don't think there's any bios settings like resizable bar or pcie config that would prevent getting a display if they got reset to stock.
Any help appreciated.
EDIT: have ordered a 3200G so I can try with no GPU and motherboard output. That's the one awkward thing with these Ryzen CPUs and no integrated graphics, makes troubleshooting a lot harder.
 
Last edited:

Colif

Win 11 Master
Moderator
Do you know if your PC was set up to boot UEFI or Legacy??

One thing that can happen is if the bios update has turned on Secure Boot, and your Boot drive is formatted as MBR, you get a blank screen at startup. It tripped up lots of people converting to using win 11.

Did you have the previous bios version installed? I would try an older version. I don't think you can go back past F14 though.

You can flash bios without seeing screen on that board, I have the X570 Aorus Elite so I know what it can do.