Question No display after installing new GPU ?

Dec 2, 2022
5
0
10
0
i just bought a new gpu radeon hd 8490 no pin power when i installed the gpu it says no cable connected i thought it might be a driver issue amd tried to switch back to the igpu but instead the igpu says no display then i asked a friend for help and we reinstalled the gpu a couple of times and it actually boot but the next morning when i tried to turn it on again
it get the same problem i tried reinstalling the gpu to no avail i have tried to clean the ram clear cmos but none seem to be working please help
 

Lutfij

Titan
Moderator
Welcome to the forums, newcomer!

You might want to start with providing details to your system, like so:
CPU:
Motherboard:
Ram:
SSD/HDD:
GPU:
PSU:
Chassis:
OS:
Monitor:
Include the age of the PSU, apart from it's make and model.
 
Dec 2, 2022
5
0
10
0
my cpu is amd: a4 3300
motherboard is : gigabyte ga55m ds2
ram is 2x2 samsung ddr3 1666
hdd is seagate 80 gb
gpu im trying to install amd hd 8490 former gpu amd hd 6410
psu is : powerstation 2 500 watt i dont know when its made but i have used it for around a month with no problem
os is windows 7
monitor 16 inch aoc
 
Dec 2, 2022
5
0
10
0
i have tested it in my friend pc the gpu and ram are fine but the motherboard still no signal is this problem caused by the psu but i never had problem with the psu no restarting sudden shutdown and any of that
 
Dec 2, 2022
5
0
10
0
My motherboard died after installing a new GPU, should I buy another mobo and re-use the old GPU, or buy a new motherboard and new GPU ?

my gpu somehow killed my motherboard. After my mothetboard died my friend tested the gpu in his pc and it booted up with no problem.
Should i buy a new motherboard and reuse the previous gpu or buy a new motherboard and gpu ? the gpu is amd hd 8490 .
 

ASK THE COMMUNITY