Question No display after pc is turned on at power point ?

Jul 12, 2021
4
0
10
0
My pc has troubles starting if i’ve just turned it on at the power point or flicked the PSU switch on. It turns on but my monitor doesn’t display and my mouse led wont light up. I usually have to leave it for a while before trying to boot to get the monitor to display. Has anyone experienced this and can offer an explanation or theory as to whats wrong?
 
Jul 12, 2021
4
0
10
0
full system spec? include brand and model of the psu
Psu: Corsair cx650
Gpu: asus gtx 1060 6gb
Cpu: ryzen 5 1600
Mobo: asrock ab350m-hdv
Ram: corsair vengeance lpx 2x(8gb) 3200mhz

A few months ago i was turning my pc off everynight at the wall since the lights got annoying as i was struggling to sleep, then less than a month ago my pc started with the monitor "no signal" problem after i would turn it back on at the wall to boot it up, so i stopped turning it off at the wall. Yesterday i got a blue screen and i went in to event viewer to find out the error and it was 0x00000116 which is video_tdr_failure, i did a bunch of fixes i could find after that and i posted here concerned that something is failing in my pc.
 
Last edited:
Jul 12, 2021
4
0
10
0
did you shut down the pc first, then unplug the power from the wall?
if not, could be the psu or gpu issue
yeah i use to shutdown the pc, then once its off i flick the power point switch off. after i started having the issues i would just turn it off then unplug my mouse since its really bright. is there a way for me to test if its either the psu or gpu thats faulty?
 

ASK THE COMMUNITY

TRENDING THREADS