Question No Display and no RGB on Mouse or Keyboard

JerryJG

Commendable
Nov 9, 2019
21
0
1,510
0
My system:
I5 6600k
Z170 Extreme 3
16GB Ram Ribjaws 2666Mhz
250gb ssd cruial
600W PSU Corsair
AiO from Cooler Master 120mm
Asus HD7970 3gb

Hey,
I recently got a weird problem. I downloaded a few games from Steam and walked away.
After some time my screen was blue. Not this blue from Windows, but a little brighter.
Then I restarted the PC, Asus logo appeared, Bios works, but then when the loading screen from Windows comes, my rgb mouse and keyboard go out and the screen goes black, but is still on and gets a signal.
Rebooted a few times and all of a sudden it went back to normal. Played games. And ran benchmarks.
Everything in the green area.
Even CMOS battery changed.
Then when starting Arma 3 the screen jerked and went black, but still a signal.
Pc started without graphics card, but the same problems occur. Applied new thermal paste and it went.
Then all of a sudden it didn't.
It didn't matter if the graphics card was inside or not.
And now the best, I have 2 Pcs with both happens this. One more often than the other. I also changed the GPU (GTX 970 from Gainward). The other Pcs works without problem when no GPU is plugged in. (I7 10700k)
Is it because of my WindowsBootStick ? Or did i get lucky and my gpus are dead ?
 
Jan 13, 2022
21
1
10
2
Hi there, quick question tho is your graphic cards okay now? or is it dead? I’ve had the same problem and the issue is my PSU, corsair psu are great but how long have you been using them?
 

DSzymborski

Titan
Moderator
My system:
I5 6600k
Z170 Extreme 3
16GB Ram Ribjaws 2666Mhz
250gb ssd cruial
600W PSU Corsair
AiO from Cooler Master 120mm
Asus HD7970 3gb

Hey,
I recently got a weird problem. I downloaded a few games from Steam and walked away.
After some time my screen was blue. Not this blue from Windows, but a little brighter.
Then I restarted the PC, Asus logo appeared, Bios works, but then when the loading screen from Windows comes, my rgb mouse and keyboard go out and the screen goes black, but is still on and gets a signal.
Rebooted a few times and all of a sudden it went back to normal. Played games. And ran benchmarks.
Everything in the green area.
Even CMOS battery changed.
Then when starting Arma 3 the screen jerked and went black, but still a signal.
Pc started without graphics card, but the same problems occur. Applied new thermal paste and it went.
Then all of a sudden it didn't.
It didn't matter if the graphics card was inside or not.
And now the best, I have 2 Pcs with both happens this. One more often than the other. I also changed the GPU (GTX 970 from Gainward). The other Pcs works without problem when no GPU is plugged in. (I7 10700k)
Is it because of my WindowsBootStick ? Or did i get lucky and my gpus are dead ?
What's the exact PSU? What's the PSU in the other PC? Corsair has sold like 8 or 9 PSUs at precisely 600W and I can only think of two (the SF ones) that are of a quality that this hardware should have ever been running on.
 

JerryJG

Commendable
Nov 9, 2019
21
0
1,510
0
What's the exact PSU? What's the PSU in the other PC? Corsair has sold like 8 or 9 PSUs at precisely 600W and I can only think of two (the SF ones) that are of a quality that this hardware should have ever been running on.
I think the pc with i7 works fine. Maybe its the HD7970. The psu is the CX600
 

DSzymborski

Titan
Moderator
I think the pc with i7 works fine. Maybe its the HD7970. The psu is the CX600
And, again, what is the PSU in that other PC that the GPUs both don't work in? And did the 970 work before you connected it to this PSU?

Do you have a quality PSU to test out these things on? The CX 600 is of ancient construction and ancient design and was never really appropriate for a 7970 in the first place.
 

JerryJG

Commendable
Nov 9, 2019
21
0
1,510
0
So now after 5min the Display goes off and the monitor has no signal. But Keyboard lights are on. And i can shut down the pc by pressing alt f4 and enter. After restart its the same.
I also changed to the VS550 PSU but same problem
 

JerryJG

Commendable
Nov 9, 2019
21
0
1,510
0
Now tried the pc with HD7970. Black screen after some time, but does give a signal. Fans are now quieter then before but not off
Keyboard doesnt work.
 

JerryJG

Commendable
Nov 9, 2019
21
0
1,510
0
I now tested a gpu that works for sure. A Gtx 285 1gb. Its not a great card but i know it works. The Pc with i5 6600k runs now smoothly and i started a couple benchmarks. No problems yet. I will let the pc run for an 1 hour or more
 

JerryJG

Commendable
Nov 9, 2019
21
0
1,510
0
So now installed the GTX 970 and new driver. Turned off sleep after 10min to never and the pc now runs without display issue for hours.
The HD7970 is dead i think
 

JerryJG

Commendable
Nov 9, 2019
21
0
1,510
0
So now installed the GTX 970 and new driver. Turned off sleep after 10min to never and the pc now runs without display issue for hours.
The HD7970 is dead i think
Edit: installed RockstarGames and the 970 has no display.
Im now prettt sure that both gpus are dead
 
Jan 13, 2022
21
1
10
2
I dont have any more to tell you, my guess is (from ur statement) the problem is with ur GPUs . This kind of problem might relate with instable voltage, in short, the electricity in your house isn’t stable, i’d recommend you to buy voltage stabilizer or i believe it is called ‘stavolt’ (?) usually second and third world country have this kind of electrical issues (my country does have this too) and since im living in indonesia, im using stavolt too. I’ve been using it for years now and it make ur electronic parts lasts longer (including ur PC coz its run by electricity) so i think its kinda makes sense. Thats it from me, goodluck and cheers mate!
 
Jan 13, 2022
21
1
10
2
I dont have any more to tell you, my guess is (from ur statement) the problem is with ur GPUs . This kind of problem might relate with instable voltage, in short, the electricity in your house isn’t stable, i’d recommend you to buy voltage stabilizer or i believe it is called ‘stavolt’ (?) usually second and third world country have this kind of electrical issues (my country does have this too) and since im living in indonesia, im using stavolt too. I’ve been using it for years now and it makes ur electronic parts lasts longer (including ur PC coz its run by electricity) so i think its kinda makes sense. Thats it from me, goodluck and cheers mate!
 

JerryJG

Commendable
Nov 9, 2019
21
0
1,510
0
I now found the issue. With the HD7970 i was able to get in the bios. I started windows in safe mode and downloaded DDU. Then I uninstalled all gpu drivers. Now the HD7970 works in Windows. But when I install any GPU driver the Pc goes black. It also make the windows disconnected sound.
Rgb is still on but no display
 

ASK THE COMMUNITY

TRENDING THREADS