Question No display - ASRock Phantom Gaming 4 motherboard

bakana42

Distinguished
Apr 11, 2012
12
0
18,510
0
I've just put together a new system, which seems to boot fine, but no image is output to the screen.

This mobo has LED post status lights (CPU, DRAM, VGA, BOOT), and when I boot up, the VGA light immediately lights up, and stays lit, which affirms the display problem, but doesn't provide more info.

I have tried connecting the monitor to the onboard HDMI slot, and the GPU HDMI slot, and tried removing the GPU altogether.

UPDATE: I've hooked up a speaker to the motherboard, and am getting three beeps, which seems to indicate a memory issue. I have 2 8GB RAM sticks, and have tried booting with each of them, one by one, in each of the four mobo RAM slots. Still, I get no image, and three beeps.

Does this indicate the problem is with the RAM (since three beeps == memory error) , or more likely with the mobo (since both separate RAM sticks yielded the error, and it's unlikely that both are bad)?

The specs are:
Mobo: ASRock H470 Phantom Gaming 4
CPU: Intel Core i5-10600K
GPU: Sapphire Radeon Nitro+ RX 590 8GB GDDR5
RAM: Crucial Ballistix 3200 MHz DDR4 DRAM
PSU: Antec EarthWatts EA650 650W Continuous Power ATX12V

Does anyone have any suggestions? The only BIOS listed on the mobo's site is the same as the sticker on my chipset, so I don't think updating it would change anything (and I'm not sure how I'd update it with no display).

I've never had an issue like this, and am feeling a bit lost.
 
Last edited:

Lutfij

Titan
Moderator
Make and model of the PSU? Why did you pair a K suffix processor with an H series chipset? You will only be able to use the rams at DDR4-2666MHz and the processor won't be overclockable in spite of being an unlocked SKU.
 

bakana42

Distinguished
Apr 11, 2012
12
0
18,510
0
take the gpu out and test with the igpu?
make and model of the psu?
As noted, I've tried removing GPU and just running from the integrated graphics, with no change.

The PSU is an Antec EarthWatts EA650 650W Continuous Power ATX12V . I've updated my original post to indicate this.
 

bakana42

Distinguished
Apr 11, 2012
12
0
18,510
0
Make and model of the PSU? Why did you pair a K suffix processor with an H series chipset? You will only be able to use the rams at DDR4-2666MHz and the processor won't be overclockable in spite of being an unlocked SKU.
I've added the PSU to the original post. It's a:
Antec EarthWatts EA650 650W Continuous Power ATX12V

I'm not interested in overclocking, so I didn't opt for a z490 board, and PCPartpicker indicated this mobo was compatible with this CPU without issue. Annoying to hear about the RAM, I suppose, though. That issue didn't come up when I was speccing parts.
 

ASK THE COMMUNITY

TRENDING THREADS