Question No display/not booting after 3 months of not powering up the pc

Noor Dhaouadi

Honorable
Sep 2, 2013
18
0
10,510
0
Hi,
I have a problem where my computer doesn't display anything on the monitor, this thing happens to me from time to time, either i can't power up the pc or when it powers up, i get no display, i have an rx 480 (was used for mining), it was working fine when gaming, but like i said from time to time, i get that problem, i had the problem also when i had my old gpu nvidia gtx 750 ti, when i manage to power up the pc, everything lights up and fans start spinning on everything except the gpu (i hear that the rx 480 doesn't spin unless under heavy strain, maybe you guys can confirm), the gpu power led glows in blue which should mean power ok but i'm not sure, but i get no display, i tried the integrated gpu and it works fine, so the monitor is ok for now, i tried removing and putting back the ram and also the cmos, still same thing, usually when this happens it gets fixed after i play with the peripherals (ram and hard disk), also, i bought a beeper to be able to locate the problem but it actually doesn't beep at all, i tried removing the ram and then it beeps (so it's working fine), i read that when a pc boots a post beep should be heard, but i don't hear anything, also, the mouse and keyboard light up when i boot the pc, but no display still, can someone help please ?

Thank you,

GPU : RX 480 8gb
Mobo : b85 g43 gaming
PSU : ocz 550w psu
 

Noor Dhaouadi

Honorable
Sep 2, 2013
18
0
10,510
0
Update : I took the gpu to a maintenace guy, we tested it, and it looks like it's the gpu, the fans do not even start, can that still be fixed ? maybe cirecuit problem ? any ideas ?
 

ASK THE COMMUNITY

TRENDING THREADS