No display on monitor

Ajhellout

Reputable
Aug 17, 2015
32
0
4,530
0
Rig built
AMD Fx6300 3.5
650VS corsair PSU
r9 270x 4gb graphic card.
there is no display on the monitor while its connected to Graphic card but when I swipe wire to motherboard. Display comes on. No display with graphic card... Display with motherboard.
please help me.
 

problematiq

Reputable
Dec 8, 2015
443
0
4,810
16
Remove the card and reinsert it, also make sure the PCI-E power is connected properly. If it still does not show up, plug the video into the motherboard and go into the bios and enable or rather set the video to PCI slot.
 
Check if GPU is properly seated on PCIe slot. Check if the power cable(s) are connected to GPU. Check different output port on GPU if possible. If that does not help, try GPU at other PCIe slot if your motherboard has one.
 

Ajhellout

Reputable
Aug 17, 2015
32
0
4,530
0


Let me try that!! Ill update you once I am done.
 

Ajhellout

Reputable
Aug 17, 2015
32
0
4,530
0

.......
my pc used to run fine. played many heavy games such as gta 5, witcher 3, BF 4, CODBO3, Primal, ... these games use to run exceptionally good on high settings.
thn I dont know why..my pc started to boot up randomly.. now its not even displaying anything.
anyways.. ill try that too.

 


Chances are, something got broken. But to find out, and what, you need to make all tests. After all, as impossible as it may sound, it could be just a loose cable.
 

Ajhellout

Reputable
Aug 17, 2015
32
0
4,530
0


Yes it is connected to PSU by two 6pin connectors.
 

ASK THE COMMUNITY