Question No Display/Post Screen

Jan 18, 2021
10
0
10
0
I recently had an issue of compatibility with CPU and MOBO that I resolved. When I boot up my PC I have no display. What can be the issue?
I tried with and without my GPU. I plugged in audio cable and got no beeps unless in stupid and it is in wrong port.
Specs:
PSU: RM 850x
CPU: Ryzen 7 3800x
MOBO: Aorus A520
GPU: R9 380x
RAM: Kingstom Hyperx

So far I've tried reseating RAM, with different sticks. No dice. The Aorus logo on mobo is red. not sure if that means anything. I do not think my mobo needs a bios update. If I do... How?
All fans are running and Everything has power, except my GPU.

Edit: I know in some cases that the PSU is the issue but it seems good. It works just fine.
 
Jan 18, 2021
10
0
10
0
I recently had an issue of compatibility with CPU and MOBO that I resolved. When I boot up my PC I have no display. What can be the issue?
I tried with and without my GPU. I plugged in audio cable and got no beeps unless in stupid and it is in wrong port.
Specs:
PSU: RM 850x
CPU: Ryzen 7 3800x
MOBO: Aorus A520
GPU: R9 380x
RAM: Kingstom Hyperx

So far I've tried reseating RAM, with different sticks. No dice. The Aorus logo on mobo is red. not sure if that means anything. I do not think my mobo needs a bios update. If I do... How?
All fans are running and Everything has power, except my GPU.

Edit: I know in some cases that the PSU is the issue but it seems good. It works just fine.
 

ASK THE COMMUNITY

TRENDING THREADS