Question No display red vga_led light on error 72

Nov 29, 2019
2
0
10
0
Hello everyone,

Movers moved my PC across country and now it won't boot up into windows, the motherboard turns on and everything looks like it is okay but no video, not onboard video, tried 2 different working video cards, tried clearing the cmos, even removing the battery for 10 minutes, nothing is working

I have a p8z77-v premium MB and there is a number at the bottom that always shows up, it looks like a 72 but it is all funky looking. It looks like the picture. View: http://imgur.com/a/xgmvCaw
 

white.a.drew

Respectable
Oct 14, 2017
645
40
2,140
41
Hello everyone,

Movers moved my PC across country and now it won't boot up into windows, the motherboard turns on and everything looks like it is okay but no video, not onboard video, tried 2 different working video cards, tried clearing the cmos, even removing the battery for 10 minutes, nothing is working

I have a p8z77-v premium MB and there is a number at the bottom that always shows up, it looks like a 72 but it is all funky looking. It looks like the picture. View: http://imgur.com/a/xgmvCaw
according to asus it's a bios failure, and is actually common to happen with that board apparently do you have the latest bios for you mobo?

BIOS
Version 2104 2013/09/164.6 MBytes
P8Z77-V PREMIUM BIOS 2104
Improve system stability.
 
Nov 29, 2019
2
0
10
0
The problem is I can't see anything on the screen to even see what the problem is. It is just black, I tried onboard graphics and 2 different video cards in all pcie slots

Update
 
Last edited:

white.a.drew

Respectable
Oct 14, 2017
645
40
2,140
41
The problem is I can't see anything on the screen to even see what the problem is. It is just black, I tried onboard graphics and 2 different video cards in all pcie slots

Update
hold a flash light to your screen in the dark and see if you can see your screen if you can then the led panel on your screen died
 

ASK THE COMMUNITY

TRENDING THREADS