Question No display - Upgraded my setup

Feb 21, 2019
3
0
10
0
Now this is going to be a long post about an issue I have been having for over a week. It all started when I just wanted to upgrade my case and harddrives.

The problem:

After changing the motherboard, I inserted everything as I should. Suddenly I realised the EZ debug was showing lights on DRAM and CPU. At first I was sceptical, but then I realised that I accidently broke some of the pins in the socket of the CPU (I have no idea how).

I went to the store, upgraded my motherboard from a Z270 to a Z370. When I put everything up again, I had a different issue. When the CPU was connected to the PSU, it would not boot past 1 second before turning off. But when I took out the CPU cable from the motherboard, it could start normally. At first I thought maybe this could be DOA (as requested by my friends), so I took the chance of returning it to get a new better version of it (Z370 Gaming carbon). I realised it was still happening, which led me to believe the impossible: that the CPU was fried.

So I bought a new CPU (i9-9900k, might be an unpopular opinion between gamers but honestly I couldn't care less about that at this point). So I put it on the socket and booted it up, it works. Except, there was no display this time. This got me extra confused, I saw the DRAM lights when booting the first 3 seconds before they disappeared again. So I looked through the web and asked my friends about thoughts and opinions, they told me that the motherboard fried the other parts.

So I bought RAM sticks this time, but it led to me the same problem. No display/cable connected (Yes, it is connected to the GPU, and yes the GPU works).

So, here I am wondering that it might be the PSU that is the problem. I got a new brand of cables to test it with tomorrow, seeing that there shouldn't be any problem with the PSU itself because of the reason that everything else works.


Things I've tried:

  • Replacing motherboard, CPU and RAM
  • Resetting CMOS
  • Breadboxing
  • Looked through the web (literally a week)
  • Taking it easy
  • Tried with one ram stick on each slot
  • Removing the GPU and connecting to the motherboard instead to see if it would work (which it didn't).
  • Tried with different monitors.
Summary:

No display, EZ Debug lights turn on for the DRAM for couple of seconds before turning off.

Specs:

  • Fractal Design Define R6 USB-C (Case)
  • i9-9900k LGA-1151 CPU
  • Nvidia GTX 980
  • Corsair Dominator DDR4 3200MHz
  • MSI Z370 Gaming Pro Carbon AC
  • Samsung EVO 970 M.2
  • WD Desktop Black 2TB
  • Corsair HX750i PSU
Please help me, give me any suggestions on what I can do. Honestly frustrated out of my own mind doing this, especially when I thought I was good at this kind of troubleshooting..

- Ådne
 
Feb 21, 2019
3
0
10
0
You need a Z390 to boot a 9900k. Most of the Z370's don't have the needed BIOS update to post with the 9900k.
I was suspicious about this aswell, but the website we use in Norway (Komplett.no) said it only supports 8th and 9th generation (which was technically correct). The problem here is that I can't update the BIOS seeing that my older processor broke down anyways (and probably wouldn't have been supported).

But honestly, I think this might be it. I bought a Z390 and returned my other motherboard with money back. Serioustly thank you for potentially solving my problems, I will update you when I get my motherboard this monday.

It is kinda embarrassing to buy a new set of RAM, a new CPU and a new motherboard when in reality I just wanted to switch cases and get a new harddrive.

Oh well, thank you anyways.
 

Similar threads


ASK THE COMMUNITY