Question No display w/ boot loop after BIOS settings change

chiken_VEVO

Prominent
Sep 28, 2019
40
3
535
0
Hey everyone. For at least 7 years now I've owned an All - in - One system (2013 model) designed by Quest (a local Greek company)...

This PC has an ECS H61H2-TI MOBO inside, a dual - core Intel Pentium CPU with integrated graphics and 12GBs of DDR3 laptop RAM (4GB + 8GB modules).

The PC, despite running almost every day for at least 12 hours for all these years now, was running fine... Unfortunately though, as I was doing some general clean ups to improve performance a bit so my dad could be more efficient with his work, I decided to check out the BIOS again to see that everything was set correctly. I first started by resetting the settings to default, turning on AHCI mode (this was already set up this way before the factory reset) for the hard disks, along with Fast Boot and setting the BIOS to run in UEFI mode and not in Legacy mode.

I had already done the exact same thing to other PCs without any issue, but unfortunately, after Exiting and Saving, the PC wouldn't display an image ever again.

It was very weird as the PC would turn on and the fans would spin, but no image would be displayed and after about 2 minutes, the PC would turn off and on again, rinse and repeat.

I understood that I messed something up, so I opened it up. Tried unplugging the built - in touch screen and plugging in a secondary one via HDMI, nothing. Tried resetting the BIOS by unplugging the CMOS battery, shorting the pins and waiting at least 5 minutes, nothing. Tried doing a POST test, nothing, the PC would still restart after 2 minutes...

After those tries I decided to RMA it to its original manufacturer. Needless to say, they probably didn't even try opening it up, told us that there were no spare parts and that it's probably a GPU issue due to the no display problem... They didn't even try to test the CPU on an LGA 1155 test bench to see if everything is OK with it...

In conclusion, does anyone know what might have happened? I know of a good third - party repair shop I could try, but is there anything else I can try myself? I honestly find it extremely unlikely that the BIOS changes I did would suddenly result in a component failing...

Thank you all in advance for the help.
 
Since you are running mismatched set of RAM sticks my guess is they were running on some nonstandard settings. Once you reset the BIOS those settings were lost and PC can't boot. If I'm correct then removing one RAM stick should let you successfully boot.
 

ASK THE COMMUNITY

TRENDING THREADS