Question No display when graphic card is powered

Oct 23, 2019
3
0
10
0
I've recently tried to plug in my Radeon sapphire nitro rx 460 that i haven't used for few months. It used to work perfectly well but now my monitor doesn't display anything when i connect card to psu. I tired connecting monitor to integrated gpu but it also doesn't work when the graphic card is powered (It works otherwise, even when card is plugged only in PCI slot). I have reset the bios and disconnected all additional hard drives and even CD rom to make sure it's not power supply problem but it still doesn't work. My pc i powering up normally and all the fans and lights on card are working, it just doesn't display anything.

If i remember correctly, I plugged this card out when my hard drive died and it's been lying around since then. ( I had to install new system on a new drive)

My motherboard is Fujitsu D2990-A1
 
Last edited:
Oct 23, 2019
15
3
25
1
Maybe bios is confused, try resetting it to normal settings. Are all connections good? I doubt it's drivers beacuse windows boots with zero problems when having even wrong drivers. Did you try myb dvi or other connection on gpu, maybe it is broken, hdmi for example tends to not have longest lifespan.
 
Oct 23, 2019
3
0
10
0
Maybe bios is confused, try resetting it to normal settings. Are all connections good? I doubt it's drivers beacuse windows boots with zero problems when having even wrong drivers. Did you try myb dvi or other connection on gpu, maybe it is broken, hdmi for example tends to not have longest lifespan.
I have resetted bios by taking out CMOS battery and tried different hdmi and dvi cables, didn't help.
 

ASK THE COMMUNITY

TRENDING THREADS