Question No display

Apr 20, 2019
11
0
10
Best answers
0
Fans spinning. Motherboard is asrock b450m-hdv. Cpu is amd ryzen 5 2400g. Ram is g.skill ripjaws v ddr4 3200mhz. Motherboard and cpu is new help!!!
 

ShadeSlayer812

Reputable
Dec 1, 2015
51
2
4,565
Best answers
10
It is almost definetly an issue with your GPU, but FIRST, run a quick idiot check. Is everything plugged in, etc. Then check for any beeping noises or POST readings.
 

remixislandmusic

Admirable
Jan 1, 2018
4,677
526
6,390
Best answers
181
Take the system down to the bare minimum.
Take all ram sticks out and put only one back in. Take your CPU out and reseat it in the socket, making sure no pins are bent. Disconnect all storage drives and video card if you have one installed in addition to the integrated GPU.
Make sure all connectors for CPU and 24 pin power are connected.
Is your monitor plugged in and detecting anything? Do you see any lights on the motherboard relating to debug.
 
Apr 20, 2019
11
0
10
Best answers
0
Take the system down to the bare minimum.
Take all ram sticks out and put only one back in. Take your CPU out and reseat it in the socket, making sure no pins are bent. Disconnect all storage drives and video card if you have one installed in addition to the integrated GPU.
Make sure all connectors for CPU and 24 pin power are connected.
Is your monitor plugged in and detecting anything? Do you see any lights on the motherboard relating to debug.
I have but no display
 

ASK THE COMMUNITY

TRENDING THREADS