Question No DP/HDMI Signal; Problem with CPU or Motherboard?

Nov 12, 2022
3
0
10
0
Background:
I built my PC in March of 2018, so it is 4.5 years old as of now. PC worked fine until this morning when GF's PC wasn't able to start up. We did some troubleshooting for her PC, finding her PSU to be faulty by plugging my PSU into her Motherboard and GPU. Afterward, I plugged my PSU's power connectors back into my motherboard and graphics card. Upon turning on my computer, I cannot seem to get a DP/HDMI signal sent to either of my monitors. Both the GPU fans and lights as well as the CPU fan turn on when I start the computer. Unplugging and plugging in my HDMI/DP cables to both the GPU HDMI/DP ports as well as the motherboard HDMI/DP ports causes the display to search for a signal (I think...) and then ultimately report back that no such signal was found. I believe that this showcases that the problem is not with my GPU, but instead either my CPU or motherboard. I do not have access to BIOS as I cannot get a display signal.

What I have tried:
Turning off and back on the computer.
Unplugging and plugging back in the PSU.
Unseating and reseating the PSU into both the motherboard and the GPU.
Unplugging and plugging back in the power cord for the monitors.
Unplugging and plugging back in the DP/HDMI ports in both the monitors as well as the motherboard/GPU DP/HDMI ports.
Unseating and reseating the GPU in the designated PCIe slot.
Unseating and reseating the GPU in an alternative PCIE slot.

Questions:
  1. Is there any way for me to fix this loss of display signal issue without any new hardware?
  2. If this is a hardware issue, how can I narrow down the issue from to the CPU/Motherboard (if these are at issue)?
Specs:
Motherboard: MSI ATX Z370-A Pro
CPU: Intel i5 8600k
GPU: MSI GTX 1060 6GB
RAM: 2x16 GB Corsair Vengeance
PSU: Corsair 550W Bronze Rating

If you read this far, thanks for reading so much into my problem.

Cheers,

JJS
 
Nov 12, 2022
3
0
10
0
Got it! Apparently I must have knocked loose a ram stick. While finagling with my motherboard, I tapped one of my ram sticks and it fell right out of its slot. Slotted that bad boy right back in there, and boom. Display found. Hope this helps someone else

Cheers,

JJS
 

ASK THE COMMUNITY

TRENDING THREADS