No Hard Disk Detected, Marvell - System Boot

awaken13

Distinguished
Nov 5, 2009
17
0
18,510
0
When ever i boot into windows i get this error message:



^This occurs after it tries to install the marvell adapter.

I don't think it is causing any problems because i can boot into windows fine, and no problems come up. but if anyone knows what this is about, any help would be appreciated. :)
 

chunkymonster

Splendid
Jan 12, 2006
3,679
0
22,960
78
Well, without knowing your system specs or what mobo you are using, I imagine that you have a mobo with a Marvel SATA/IDE controller on board and it is listed as boot device and when the computer starts up it is looking at the Marvell controller for a boot device and then moving down the boot priority list until it boots off the hard drive connected to the chipset SATA controller.
 

awaken13

Distinguished
Nov 5, 2009
17
0
18,510
0
P6T Delux v2
i7 920
patriot 6g ddr3
2x caviar black 640 in raid 0

My first boot device is the hard drive, so unless every time you boot from the hard drive it tries to the Marvell controller i don't see how that could be the issue.
 

kaou

Distinguished
Dec 3, 2009
12
0
18,510
0
You need to disable the Marvell controller in the BIOS. It is checking for a IDE HDD, which I assume it doesn't need to do, since you probably use SATA.
 
It's a pretty alarming message, considering that for the vast majority of users, it has nothing to do with their main hard drive. It isn't hurting anything. I have a machine that's been displaying the same message at startup every time for a year, and it runs like the day I built it.

A lot of ASUS boards do that by default. All of the ones I've worked with recently, anyway. The Marvell controller handles IDE and eSATA ports on ASUS boards ... all that message basically means is that you don't have anything plugged into the IDE or eSATA ports -- no big deal, since in your case, those would just be accessory drives.

If the message is annoying you, you can probably get rid of it by disabling the controller as others have said. But I believe that may also turn off your eSATA ports in addition to the IDE ports. So if you have an external hard drive that you plug in there on a regular basis, you may want to leave it alone. If you don't have an external hard drive, you won't be missing anything.


 

awaken13

Distinguished
Nov 5, 2009
17
0
18,510
0
Alright, thanks for all the help everyone. I guess ill just go ahead and disable the marvell controller in the bios since i don't use any external HDDs.
 
G

Guest

Guest
Disabling the marvel port for external hard drives does it also meaning disabling like USB connected harddrives?
 

kaou

Distinguished
Dec 3, 2009
12
0
18,510
0
Disabling the marvel port for external hard drives does it also meaning disabling like USB connected harddrives?
No it doesn't. It will only disable HDDs connected through IDE, typically used inside of your computer. The USB harddrives should still work.
 

Darkterror58

Distinguished
Oct 21, 2011
1
0
18,510
0
First of all many thanks again to Tony919 from Legit Reviews forum for the useful advice!!! (from 2006!!!)

I have my son's desktop PC from 2007 with Intel Bad Axe 2 D975XBX2 motherboard, chipset Intel Glenwood-DG i975X. I just reinstalled partition C: (progs&apps) with Win 7 64 ultimate (reinstalled 3rd time in 3 years). But this was the first time I faced the Marvell Controller said:

No array
No HDD etc. already written by others in the forum.

We have the latest BIOS available from 2009. and I tried what Tony919 suggested:

"go to BIOS setup, select Advanced - Peripheral Configuration - (disable) Secondary SATA Controller."


I did it and it works with my son's PC. I tell you frankly, first I was afraid that after that PC won't see the third HDD (1.5 Tb, which I placed later in 2010 as "container" for movies), but everything is O.K.

So I strongly suggest to do what Tony919 suggested and Marvell Controller won't appear again with bothering messages.

Thank you Tony once again!
 

lintok

Honorable
Mar 14, 2012
1
0
10,510
0
I have a similar issue, and i want to disable it. I only use one hdd which is connected to 1 of the 2 sata 6gb/s port, my mobo is an h67.

On the bios -> advanced mode -> onboard devices configuration

there are two options for marvell

>Marvell Storage Controller &
>Marvell Storage OPROM

both are enabled, which one should i disable? :p
 

Similar threads


TRENDING THREADS