No hard disk detected!, then Windows boots

stotic

Distinguished
Feb 4, 2010
11
0
18,510
0
Hello,

Just finished building a pc for the first time. Some pieces I have on it include:
- ASUS P7P55D-E Pro LGA 1156 Intel P55 SATA 6Gb/s USB 3.0 ATX Intel Motherboard
- Intel Core i5-750
- Western Digital Caviar Black WD1001FALS 1TB 7200 RPM SATA 3.0Gb/s 3.5" Internal Hard Drive -Bare Drive

When I boot, I see the motherboard screen, then the screen goes black and appears with the message:

"Warning: No hard disk detected!"

5 seconds go by, then Windows boots perfectly fine.

I can see the drive in Bios and the HD is first in the boot order. The HD and the DVD drive are in sata 1 & 2.

This is baffling myself and my computer literate friends. Any ideas?
 

stotic

Distinguished
Feb 4, 2010
11
0
18,510
0
I'm not sure what you mean by booting right (it's booting into Windows eventually). The problem is that every time my computer boots up, it wastes 10 seconds because i see a screen that says "No Hard Drive Detected!", but then ironically boots into Windows.
 

shortstuff_mt

Glorious
Moderator
Under "Advanced" and "Onboard Devices Configuration" there are options to set the JMicron SATA/PATA Controller and Marvel 9123 SATA Controller to different modes. They should not be set to IDE mode if you don't have any IDE devices.
 

stotic

Distinguished
Feb 4, 2010
11
0
18,510
0


Sorry I missed this. I see this in the BIOS. I can either set them both to IDE Mode or Disabled mode. I should set it to disabled?
 

stotic

Distinguished
Feb 4, 2010
11
0
18,510
0


I can disable the JMicron controllers


The only other mode for the other controller besides IDE and Disabled is AHCI mode.
 

Dave in Houston

Distinguished
Apr 5, 2010
5
0
18,510
0
Any more information on this question? On my very similar system, disabling the JMicro controller doesn't help. The message seems to be coming from a "Marvell" controller, but that's not shown in the BIOS.

This is not a huge problem, but it's an annoyance.

Thanks!
 

an5311

Reputable
Nov 21, 2015
3
0
4,520
1
I had exactly the same problem, albeit with a P5Q-E motherboard. I changed a couple of settings in BIOS, but what I am pretty sure did the trick was disabling Marvell IDE in Advanced -> Onboard Device Configuration.
 

stotic

Distinguished
Feb 4, 2010
11
0
18,510
0


Wow this thread is still alive! So after all these years I still haven't found a fix, I've sort of just lived with it.

an5311, there isn't a a Marvell IDE option. Are you sure you weren't referring to Marvell 9123 SATA Controller?
 

an5311

Reputable
Nov 21, 2015
3
0
4,520
1

I have come across this thread when I was looking for a solution to the same problem as you described. I could not find a definitive answer, so I started going through my BIOS settings and turning off everything that was not necessary. The message that you described disappeared after I disabled Marvell IDE. However, our motherboards, controllers and BIOSs are different.

I use all my SATA drives in AHCI and have all IDE options (for hard drives) disabled (or set to 0). Are all your drives SATAs? If so, then I think that you should use the AHCI setting as it offers several advantages over IDE, and performance boost is one of them (see e.g., AHCI vs. IDE). However, if your current setting is IDE, then you might have to reinstall Windows after switching to AHCI (see e.g., Can I switch from AHCI to IDE without re-format/re-install?). After you have all your drives working in AHCI, then you should disable all your IDE options (for hard drives).
 

Similar threads


ASK THE COMMUNITY